]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: fix native dependency
authorQing He <qing.he@intel.com>
Wed, 17 Nov 2010 08:26:58 +0000 (16:26 +0800)
committerSaul Wold <sgw@linux.intel.com>
Mon, 22 Nov 2010 18:30:30 +0000 (10:30 -0800)
disable gnutls for -native
also fix --with-gnutls parameter for target

Signed-off-by: Qing He <qing.he@intel.com>
meta/recipes-support/curl/curl_7.21.2.bb

index 1e11222897eb636e690910a0d8fd40a8cfca9627..fd1d5ddf759103e0307f0b2ed0175a0bda1d646e 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e66
 DEPENDS = "zlib gnutls"
 DEPENDS_virtclass-native = "zlib-native"
 DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
            file://noldlibpath.patch \
@@ -17,7 +17,6 @@ SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
 inherit autotools pkgconfig binconfig
 
 EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
-                --with-gnutls=${STAGING_BINDIR_CROSS}/ \
                 --without-ssl \
                 --without-libssh2 \
                --with-random=/dev/urandom \
@@ -25,6 +24,10 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
                --enable-crypto-auth \
                "
 
+EXTRA_OECONF_append = " --with-gnutls=${STAGING_LIBDIR}/../"
+EXTRA_OECONF_virtclass-native_append = " --without-gnutls"
+EXTRA_OECONF_virtclass-nativesdk_append = " --without-gnutls"
+
 do_configure_prepend() {
        sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac
 }