]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: add python and bash dependencies
authorTom Zanussi <tom.zanussi@linux.intel.com>
Fri, 1 Mar 2013 17:34:57 +0000 (11:34 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 2 Mar 2013 12:54:03 +0000 (12:54 +0000)
There are a number of scripts in the systemtap installation that use
python and bash, so we need to add run-time dependencies for them.  If
not, we can generate build errors like "no package provides
/usr/bin/python".

Fixes [YOCTO #3951].

Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/systemtap/systemtap_git.bb

index 7fc92c8487293c66864fb3bd0a1c6d3cde6b6a56..22f89599cfc957508547009080177e45896a7fba 100644 (file)
@@ -6,6 +6,10 @@ DEPENDS = "elfutils sqlite3 systemtap-native"
 DEPENDS_class-native = "elfutils-native sqlite3-native gettext-native"
 DEPENDS_class-nativesdk = "nativesdk-elfutils nativesdk-sqlite3 nativesdk-gettext"
 
+RDEPENDS_${PN} += "python bash"
+RDEPENDS_${PN}_class-native += "python-native"
+RDEPENDS_${PN}_class-nativesdk += "python-native"
+
 PR = "r1"
 
 EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \