]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/5.0: fix systemtap for arm
authorBruce Ashfield <bruce.ashfield@gmail.com>
Fri, 8 Mar 2019 19:31:48 +0000 (14:31 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 9 Mar 2019 14:41:20 +0000 (14:41 +0000)
We need to enable the arm unwinder for systemtap to work out of the
box:

  root@qemuarm:~# stap --disable-cache -DSTP_NO_VERREL_CHECK ./hello.stp
  [ 1600.955262] stap_2097: loading out-of-tree module taints kernel.
  hello world

This option is useful for much more than systemtap, so it is a good
idea to have on in the base configs. It make the image slightly larger,
but has no performance impacts.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_5.0.bb
meta/recipes-kernel/linux/linux-yocto-tiny_5.0.bb
meta/recipes-kernel/linux/linux-yocto_5.0.bb

index a757945f8dfd826f63b1e0dae48b780dd7e969e3..2350973fef2a9c009840a6151566938d6e607618 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
-SRCREV_meta ?= "be627e4e38626c5e949de04c814ebd2487d5dd98"
+SRCREV_meta ?= "4faa4419884d2bbe65f637befd71a1e95629eaae"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.0;destsuffix=${KMETA}"
index 57aada3f62c52613bdf94c2897647dc3e0241249..e0a68014461bffcc36a01924cab90a1a3ac81692 100644 (file)
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine_qemuarm ?= "6da91ac9afd3b8c144760e3ceacc6a812ddfa3f6"
 SRCREV_machine ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
-SRCREV_meta ?= "be627e4e38626c5e949de04c814ebd2487d5dd98"
+SRCREV_meta ?= "4faa4419884d2bbe65f637befd71a1e95629eaae"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index a56e9a19d8ba6a90c63d281fd5805bd06984138e..f2c066a1503637df170703a726ffa146a6dc1ed9 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
 SRCREV_machine_qemux86-64 ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
 SRCREV_machine_qemumips64 ?= "5f072445126e6a9e44f9435a552f4fcf6fc15499"
 SRCREV_machine ?= "1a0da7e50b77c82841efb501c648dbaca699eac2"
-SRCREV_meta ?= "be627e4e38626c5e949de04c814ebd2487d5dd98"
+SRCREV_meta ?= "4faa4419884d2bbe65f637befd71a1e95629eaae"
 
 # remap qemuarm to qemuarma15 for the 5.0 kernel
 # KMACHINE_qemuarm ?= "qemuarma15"