]> code.ossystems Code Review - openembedded-core.git/commitdiff
detect-stylus: Add for now until I teach udev how to do this instead
authorRichard Purdie <richard@openedhand.com>
Mon, 12 Jun 2006 12:47:18 +0000 (12:47 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 12 Jun 2006 12:47:18 +0000 (12:47 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@463 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch [new file with mode: 0644]
openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch [new file with mode: 0644]
openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch [new file with mode: 0644]
openembedded/packages/detect-stylus/detect-stylus_0.13.bb [new file with mode: 0644]

diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch
new file mode 100644 (file)
index 0000000..cd8c520
--- /dev/null
@@ -0,0 +1,17 @@
+Index: detect-stylus.c
+===================================================================
+RCS file: /cvs/gpe/base/detect-stylus/detect-stylus.c,v
+retrieving revision 1.12
+retrieving revision 1.13
+diff -u -r1.12 -r1.13
+--- detect-stylus.c    8 Sep 2004 15:57:15 -0000       1.12
++++ detect-stylus.c    9 Sep 2004 23:08:42 -0000       1.13
+@@ -131,7 +131,7 @@
+       XChangeProperty (dpy, root, atom, XA_INTEGER, 8, PropModeReplace, &b, 1);
+       XCloseDisplay (dpy);
+-      if (!access("/usr/bin/xrdb", X_OK))
++      if (access("/usr/bin/xrdb", X_OK))
+         system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
+       else
+         system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/bin/xrdb -nocpp -merge");
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch
new file mode 100644 (file)
index 0000000..7c8213d
--- /dev/null
@@ -0,0 +1,15 @@
+diff -urNd ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c detect-stylus-0.13/detect-stylus.c
+--- ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c        2004-09-08 16:56:58.000000000 +0100
++++ detect-stylus-0.13/detect-stylus.c 2004-09-13 21:36:03.000000000 +0100
+@@ -132,9 +132,9 @@
+       XCloseDisplay (dpy);
+       if (access("/usr/bin/xrdb", X_OK))
+-        system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
++        system ("echo \"Matchbox.cursor: no\nXcursor.theme: xcursor-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
+       else
+-        system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/bin/xrdb -nocpp -merge");
++        system ("echo \"Matchbox.cursor: no\nXcursor.theme: xcursor-transparent\" | /usr/bin/xrdb -nocpp -merge");
+     }
+       
+   exit (0);
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch
new file mode 100644 (file)
index 0000000..94542b1
--- /dev/null
@@ -0,0 +1,13 @@
+diff -urNd ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c detect-stylus-0.13/detect-stylus.c
+--- ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c        2004-09-08 16:56:58.000000000 +0100
++++ detect-stylus-0.13/detect-stylus.c 2004-09-18 23:43:12.000000000 +0100
+@@ -62,6 +62,9 @@
+   if (fd < 0) 
+     fd = try_open ("/dev/touchscreen/ucb1x00");
++  if (fd < 0) 
++    fd = try_open ("/dev/ts");
++
+   if (fd < 0)
+     {
+       DIR *d;
diff --git a/openembedded/packages/detect-stylus/detect-stylus_0.13.bb b/openembedded/packages/detect-stylus/detect-stylus_0.13.bb
new file mode 100644 (file)
index 0000000..793cbef
--- /dev/null
@@ -0,0 +1,18 @@
+inherit gpe pkgconfig
+LICENSE = "GPL"
+
+PR = "r2"
+
+DEPENDS = "libx11 xcursor-transparent-theme xrdb"
+SECTION = "gpe"
+RDEPENDS = "xrdb"
+
+DESCRIPTION = "Touchscreen detection utility"
+MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz \
+           file://access.patch;patch=1;pnum=0 \
+          file://extra-device-check.patch;patch=1 \
+          file://correct-theme-name.patch;patch=1"
+
+export CVSBUILD="no"