]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: added 2.3.5
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 1 Aug 2007 12:43:57 +0000 (12:43 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 1 Aug 2007 12:43:57 +0000 (12:43 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2271 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/freetype/freetype-2.3.5/fix-x86_64-build.patch [new file with mode: 0644]
meta/packages/freetype/freetype-native_2.3.5.bb [new file with mode: 0644]
meta/packages/freetype/freetype_2.3.5.bb [new file with mode: 0644]

diff --git a/meta/packages/freetype/freetype-2.3.5/fix-x86_64-build.patch b/meta/packages/freetype/freetype-2.3.5/fix-x86_64-build.patch
new file mode 100644 (file)
index 0000000..ae504dc
--- /dev/null
@@ -0,0 +1,26 @@
+Index: freetype-2.3.1/builds/unix/configure.raw
+===================================================================
+--- freetype-2.3.1.orig/builds/unix/configure.raw
++++ freetype-2.3.1/builds/unix/configure.raw
+@@ -40,7 +40,7 @@ AC_SUBST(EXEEXT)
+ # checks for native programs to generate building tool
+ if test ${cross_compiling} = yes; then
+-  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build-gcc})
++  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build}-gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, gcc, gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, cc, cc, , , /usr/ucb/cc)
+   test -z "${CC_BUILD}" && AC_MSG_ERROR([cannot find native C compiler])
+Index: freetype-2.3.1/builds/unix/configure.ac
+===================================================================
+--- freetype-2.3.1.orig/builds/unix/configure.ac
++++ freetype-2.3.1/builds/unix/configure.ac
+@@ -40,7 +40,7 @@ AC_SUBST(EXEEXT)
+ # checks for native programs to generate building tool
+ if test ${cross_compiling} = yes; then
+-  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build-gcc})
++  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build}-gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, gcc, gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, cc, cc, , , /usr/ucb/cc)
+   test -z "${CC_BUILD}" && AC_MSG_ERROR([cannot find native C compiler])
diff --git a/meta/packages/freetype/freetype-native_2.3.5.bb b/meta/packages/freetype/freetype-native_2.3.5.bb
new file mode 100644 (file)
index 0000000..b5e8b30
--- /dev/null
@@ -0,0 +1,21 @@
+require freetype_${PV}.bb
+inherit native
+DEPENDS = ""
+FILESPATH = "${FILE_DIRNAME}/freetype-${PV}:${FILE_DIRNAME}/freetype:${FILE_DIRNAME}/files"
+
+EXTRA_OEMAKE=
+
+do_configure() {
+       (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
+       oe_runconf
+}
+
+do_stage() {
+       autotools_stage_includes
+       oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+do_install() {
+       :
+}
+
diff --git a/meta/packages/freetype/freetype_2.3.5.bb b/meta/packages/freetype/freetype_2.3.5.bb
new file mode 100644 (file)
index 0000000..c1febe8
--- /dev/null
@@ -0,0 +1,41 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+           file://fix-x86_64-build.patch;patch=1 \
+           file://no-hardcode.patch;patch=1 \
+         "
+
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+DEFAULT_PREFERENCE = "-1"
+
+LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+EXTRA_OECONF = "--without-zlib"
+
+do_configure() {
+       cd builds/unix
+       gnu-configize
+       aclocal -I .
+       autoconf
+       cd ${S}
+       oe_runconf
+}
+
+do_compile_prepend() {
+       ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+do_stage() {
+     export LIBTOOL='${LIBTOOL}'
+        autotools_stage_all
+        oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"