]> code.ossystems Code Review - openembedded-core.git/commitdiff
make-mod-scripts: Fix a rare build race condition
authorKhem Raj <raj.khem@gmail.com>
Wed, 27 May 2020 20:51:07 +0000 (13:51 -0700)
committerSteve Sakoman <steve@sakoman.com>
Sat, 30 May 2020 22:12:42 +0000 (12:12 -1000)
There is a build break which rarely happens but is seen often enough
with 4.1 kernel based builds

/bin/sh: 1: scripts/basic/fixdep: Permission denied
scripts/Makefile.host:124: recipe for target 'scripts/dtc/srcpos.o' failed
make[3]: *** [scripts/dtc/srcpos.o] Error 126

this patch sequences the build targets so it can work reliably with
different kernel versions

Divide the target into scripts_basic scripts is not
strictly necessary and was simply what was used for
testing on kernel 4.1, which is quite an old kernel

perhaps just using scripts is sufficient, but it is not tested to not
known will cause the build race as seen above.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 55ac6e2d251287419138931aa0d0894cf1267787)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb

index 0be1422a24fae341f07ee6794e88c2fe3e6aa7ba..c7edb20ee4cf7c24ac99807c046765489932fda9 100644 (file)
@@ -23,7 +23,8 @@ EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="
 #
 do_configure() {
        unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
-       oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
-                  -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts prepare
-
+       for t in prepare scripts_basic scripts; do
+               oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
+               -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t
+       done
 }