]> code.ossystems Code Review - openembedded-core.git/commitdiff
insane.bbclass: special case gettext as it can't depend on itself
authorJoshua Lock <josh@linux.intel.com>
Tue, 22 Dec 2009 17:17:55 +0000 (17:17 +0000)
committerJoshua Lock <josh@linux.intel.com>
Mon, 4 Jan 2010 10:34:00 +0000 (10:34 +0000)
Only run the gettext section of the QA configure sanity check if
the package is not gettext as the gettext tools, shipped with
gettext, use the macro employed in the sanity check.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/classes/insane.bbclass

index 9fc8873f22e04bc3d91efb00cc23c8fd0d10189f..9bddb9bd425c2f67193b32813f4c915c9940a263 100644 (file)
@@ -500,14 +500,15 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
         if "configure.in" in files:
             configs.append(os.path.join(root, "configure.in"))
 
-    if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
-       gt = "gettext-native"
-    else:
-       gt = "gettext"
-    deps = bb.utils.explode_deps(bb.data.getVar('DEPENDS', d, True) or "")
-    if gt not in deps:
-       for config in configs:
-           gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config
-           if os.system(gnu) == 0:
-              bb.fatal("Gettext required but not in DEPENDS for file %s" % config)
+    if "gettext" not in bb.data.getVar('P', d, True):
+       if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
+          gt = "gettext-native"
+       else:
+          gt = "gettext"
+       deps = bb.utils.explode_deps(bb.data.getVar('DEPENDS', d, True) or "")
+       if gt not in deps:
+          for config in configs:
+              gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config
+              if os.system(gnu) == 0:
+                 bb.fatal("Gettext required but not in DEPENDS for file %s" % config)
 }