]> code.ossystems Code Review - openembedded-core.git/commitdiff
nativesdk-bison: Add to nativesdk-packagegroup-sdk-host and set BISON_PKGDATADIR
authorHe Zhe <zhe.he@windriver.com>
Fri, 28 Sep 2018 03:18:24 +0000 (11:18 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Oct 2018 14:25:35 +0000 (15:25 +0100)
bison is needed when building kernel. Add it to nativesdk-packagegroup-sdk-host
and set BISON_PKGDATADIR for bison to use its components.

Signed-off-by: He Zhe <zhe.he@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
meta/recipes-devtools/bison/bison_3.0.4.bb

index e2f61699946048fbac92fe493462ec376e14c877..448c2f6de420acedd7c6a11664ff06adcdd56254 100644 (file)
@@ -25,6 +25,7 @@ RDEPENDS_${PN} = "\
     nativesdk-cmake \
     ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-wayland', '', d)} \
     nativesdk-sdk-provides-dummy \
+    nativesdk-bison \
     "
 
 RDEPENDS_${PN}_darwin = "\
index cc155f0fbe3cbe508140ea720223144eb28d7e31..f1b05da4169158645103363b9ed5e8aeb2c22e0d 100644 (file)
@@ -36,4 +36,8 @@ do_install_append_class-native() {
        create_wrapper ${D}/${bindir}/bison \
                BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
 }
+do_install_append_class-nativesdk() {
+       create_wrapper ${D}/${bindir}/bison \
+               BISON_PKGDATADIR=${datadir}/bison
+}
 BBCLASSEXTEND = "native nativesdk"