]> code.ossystems Code Review - openembedded-core.git/commitdiff
attr/acl: add SSTATEPOSTINSTFUNC
authorSaul Wold <sgw@linux.intel.com>
Sat, 24 Sep 2011 18:56:47 +0000 (11:56 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 25 Sep 2011 14:25:54 +0000 (15:25 +0100)
Added a native sstate post install function to fix the links
created between /lib and /usr/lib for the library files. These
links could point to an invalid build area when using shared state.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/attr/acl_2.2.51.bb
meta/recipes-support/attr/attr_2.4.46.bb
meta/recipes-support/attr/ea-acl.inc

index 18aac7c3e78bc18e5db065021adfe90ff4efe1b5..40ba5f119f93995ec8882122c48e2211833b9c5e 100644 (file)
@@ -1,6 +1,6 @@
 require acl.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI[md5sum] = "3fc0ce99dc5253bdcce4c9cd437bc267"
 SRC_URI[sha256sum] = "06854521cf5d396801af7e54b9636680edf8064355e51c07657ec7442a185225"
index fe8ab791f8aab8db7a41f36fc7190b3fe3d64609..85c35d0c330d0934ddd7fe651a429de2b09fc156 100644 (file)
@@ -1,6 +1,6 @@
 require attr.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI[md5sum] = "db557c17fdfa4f785333ecda08654010"
 SRC_URI[sha256sum] = "dcd69bdca7ff166bc45141eddbcf21967999a6b66b0544be12a1cc2fd6340e1f"
index 2ef138957e78af133d5183b265ddde635a6fb042..22d7848fbfc705e92e2e078b8083e9d636ba9002 100644 (file)
@@ -35,3 +35,20 @@ BBCLASSEXTEND = "native"
 # Only append ldflags for target recipe and if USE_NLS is enabled
 LDFLAGS_append_libc-uclibc = "${@['', ' -lintl '][(bb.data.getVar('PN', d, True) == bb.data.getVar('BPN', d , True)) and (bb.data.getVar('USE_NLS', d, True) == 'yes')]}"
 EXTRA_OECONF_append_libc-uclibc = "${@['', ' --disable-gettext '][(bb.data.getVar('PN', d, True) == bb.data.getVar('BPN', d , True)) and (bb.data.getVar('USE_NLS', d, True) == 'no')]}"
+
+fix_symlink () {
+       # Remove bad symlinks & create the correct symlinks
+       if test -L ${libdir}/lib${BPN}.so ; then
+               rm -rf ${libdir}/lib${BPN}.so
+               ln -sf ${base_libdir}/lib${BPN}.so ${libdir}/lib${BPN}.so
+       fi
+       if test -L ${base_libdir}/lib${BPN}.a ; then
+               rm -rf ${base_libdir}/lib${BPN}.a
+               ln -sf ${libdir}/lib${BPN}.a ${base_libdir}/lib${BPN}.a
+       fi
+       if test -L  ${base_libdir}/lib${BPN}.la ; then
+               rm -rf ${base_libdir}/lib${BPN}.la
+               ln -sf ${libdir}/lib${BPN}.la ${base_libdir}/lib${BPN}.la
+       fi
+}
+SSTATEPOSTINSTFUNCS_virtclass-native += "fix_symlink"