]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix packaging for eds-dbus
authorChris Lord <chris@openedhand.com>
Thu, 29 Sep 2005 16:14:29 +0000 (16:14 +0000)
committerChris Lord <chris@openedhand.com>
Thu, 29 Sep 2005 16:14:29 +0000 (16:14 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@73 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/eds/eds-dbus_svn.bb

index 6f8acf2057c062490e42d0cbc49918bd51fff9c3..be803a7658a18424801042923065023957e1920f 100755 (executable)
@@ -16,8 +16,19 @@ S = "${WORKDIR}/trunk"
 
 inherit autotools pkgconfig
 
-EXTRA_OECONF = "--without-openldap --disable-nntp --disable-gtk-doc --with-dbus=yes --with-libgnome=no --enable-soup=no --with-libdb43=${STAGING_DIR}/${HOST_SYS} --enable-smime=no --enable-nss=no"
+EXTRA_OECONF = "--without-openldap --disable-nntp --disable-gtk-doc --with-dbus=yes --with-libgnome=no --enable-soup=no --with-libdb43=${STAGING_DIR}/${HOST_SYS} --enable-smime=no --enable-nss=no --disable-camel"
 
 acpaths = " -I ${STAGING_DATADIR}/aclocal/gnome-macros "
 
-do_configure_append = " cp ${WORKDIR}/iconv-detect.h ${S} "
\ No newline at end of file
+FILES_${PN} += "${libdir}/evolution-data-server-1.2/extensions/*.so \
+                ${libdir}/evolution-data-server-1.2/camel-providers/*.so \
+                ${libdir}/evolution-data-server-1.2/camel-providers/*.urls \
+                ${datadir}/evolution-data-server-1.4/zoneinfo/zones.tab \
+                ${datadir}/evolution-data-server-1.4/zoneinfo/*/*.ics \
+                ${datadir}/evolution-data-server-1.4/zoneinfo/*/*/*.ics \
+                ${datadir}/dbus-1/services/*.service"
+
+FILES_${PN}-dev += "${libdir}/evolution-data-server-1.2/extensions/*.la \
+                    ${libdir}/evolution-data-server-1.2/camel-providers/*.la"
+
+do_configure_append = " cp ${WORKDIR}/iconv-detect.h ${S} "