]> code.ossystems Code Review - openembedded-core.git/commitdiff
kern-tools: use Makefile provided install rules
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 22 Nov 2011 22:35:07 +0000 (17:35 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 2 Dec 2011 15:19:46 +0000 (15:19 +0000)
Previously the install of the kern-tools was manual and fully controlled by
whatever build system was integrating/using the utilities. To make this more
generic a Makefile is now provided to take care of installing and removing to
DESTDIR.

Updating the kern-tools recipe to take advantage of this new facility.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb

index ef078cef2a99660d9b355f05250585d6e82aa4c8..fb66211e7da6796a4b3427e0afec75b29fb36c6c 100644 (file)
@@ -4,8 +4,8 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
 
 DEPENDS = "git-native guilt-native"
 
-SRCREV = "364437739c45a5e771d1f7b3ac73c35f1328fd97"
-PR = r11
+SRCREV = "eb3ed64cea80d23ffb28dfeaeb02cdfe3fb29340"
+PR = r12
 PV = "0.1+git${SRCPV}"
 
 inherit native
@@ -13,19 +13,11 @@ inherit native
 SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git;protocol=git"
 S = "${WORKDIR}"
 
-kern_tools_LIST = kgit kgit-init kgit-meta \
-                  kgit-checkpoint kgit-clean \
-                  generate_cfg kconf_check configme \
-                 createme updateme patchme get_defconfig scc \
-                  pre_config merge_config.sh
-
 do_compile() { 
        :
 }
 
 do_install() {
-       install -d ${D}${bindir}
-       for s in ${kern_tools_LIST}; do
-           install -m 0755 ${S}/git/tools/$s ${D}${bindir}
-       done
+       cd ${S}/git
+       make DESTDIR=${D}${bindir} install
 }