]> code.ossystems Code Review - openembedded-core.git/commitdiff
librsvg: disable Bsymbolic if it is not supported on some hosts
authorChong Lu <Chong.Lu@windriver.com>
Mon, 18 Aug 2014 09:49:18 +0000 (17:49 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Aug 2014 19:43:11 +0000 (20:43 +0100)
When trying to build on my Centos 5.5 machine, got below error:
| checking for gdk-pixbuf-query-loaders... /home/build/clu1/build/qemux86_standard_glibc-std/bitbake_build/tmp/sysroots/x86_64-linux/usr/bin/gdk-pixbuf-query-loaders
| checking if gcc  supports "-Wl,-Bsymbolic-functions" flag...
| configure: error: -Bsymbolic requested but not supported by ld. Use --disable-Bsymbolic to disable
| Configure failed. The contents of all config.log files follows to aid debugging
| ERROR: oe_runconf failed

Set --enable-Bsymbolic=auto to disable it when it is not suppported.

Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/librsvg/librsvg_2.40.2.bb

index 34d8ca1bf8fb686acab46bbc03de44f8a0f02d46..e2b26f5ae7bf5754206c1c2510ad9e3a1d3654a5 100644 (file)
@@ -22,6 +22,10 @@ SRC_URI[archive.sha256sum] = "48049b643294636df7de1a4b997414d699666f5dc44776945c
 
 EXTRA_OECONF = "--disable-introspection --disable-vala"
 
+# The older ld (2.22) on the host (Centos 6.5) doesn't have the
+# -Bsymbolic-functions option, we can disable it for native.
+EXTRA_OECONF_append_class-native = " --enable-Bsymbolic=auto"
+
 PACKAGECONFIG ??= "gdkpixbuf"
 # The gdk-pixbuf loader
 PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"