]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/linux-libc-headers-yocto: Adjust to git fetcher improvements
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 2 Feb 2011 17:16:36 +0000 (17:16 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 2 Feb 2011 17:19:18 +0000 (17:19 +0000)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel-yocto.bbclass
meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
meta/recipes-kernel/linux/linux-yocto_git.bb

index 70521a4fb36abcaa4b4434831c57d565092d9c09..9ca7758bb8d4a49bfbea92fbabd05c3486b84bc9 100644 (file)
@@ -89,11 +89,11 @@ do_patch() {
 }
 
 do_kernel_checkout() {
-       if [ -d ${WORKDIR}/.git/refs/remotes/origin ]; then
+       if [ -d ${WORKDIR}/git/.git/refs/remotes/origin ]; then
                echo "Fixing up git directory for ${LINUX_KERNEL_TYPE}/${KMACHINE}"
                rm -rf ${S}
                mkdir ${S}
-               mv ${WORKDIR}/.git ${S}
+               mv ${WORKDIR}/git/.git ${S}
        
                if [ -e ${S}/.git/packed-refs ]; then
                        cd ${S}
index 762b6a8d2442021d8db66d5bdf362d0d4644f6dc..0d5835401e58c8f800424239876f31da2d0a5215 100644 (file)
@@ -10,8 +10,7 @@ PV = "2.6.37+git-${SRCPV}"
 PR = "r2"
 
 SRCREV_FORMAT = "meta_machine"
-SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
-           git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta"
+SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
 
 set_arch() {
        case ${TARGET_ARCH} in
index b1486bce18cf9d083975fed00bcfc8f7ee6c00a0..1757c5532a188879347204798d5046c86bedf7be 100644 (file)
@@ -17,8 +17,7 @@ PR = "r15"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 SRCREV_FORMAT = "meta_machine"
 
-SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
-           git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta \
+SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta \
            file://tools-perf-no-scripting.patch"
 
 COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|mpc8315e-rdb|routerstationpro)"