]> code.ossystems Code Review - openembedded-core.git/commitdiff
ofono: use patch sent upstream instead of sed
authorRoss Burton <ross.burton@intel.com>
Mon, 29 Jan 2018 17:11:11 +0000 (17:11 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 Jan 2018 23:05:52 +0000 (23:05 +0000)
Instead of using a sed to fix the hashbang in a test tool send a patch upstream
and use that.  This way we'll notice when the patch doesn't need to be applied
anymore.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/ofono/ofono.inc
meta/recipes-connectivity/ofono/ofono/use-python3.patch [new file with mode: 0644]
meta/recipes-connectivity/ofono/ofono_1.22.bb

index 4443a95c2f74128c830fa543d0a7f80194a8a5ca..0472414b199e990af34a8b1cfb73c2bc8f8ba8d8 100644 (file)
@@ -26,9 +26,6 @@ SYSTEMD_SERVICE_${PN} = "ofono.service"
 do_install_append() {
   install -d ${D}${sysconfdir}/init.d/
   install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
-
-  # Ofono still has one test tool that refers to Python 2 in the shebang
-  sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/ofono/test/set-ddr
 }
 
 PACKAGES =+ "${PN}-tests"
diff --git a/meta/recipes-connectivity/ofono/ofono/use-python3.patch b/meta/recipes-connectivity/ofono/ofono/use-python3.patch
new file mode 100644 (file)
index 0000000..7b84075
--- /dev/null
@@ -0,0 +1,27 @@
+set-ddr should use Python3 like all the other tests.
+
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 17b69cd1da4c5c5f732acb38ca1602446c567ee7 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Mon, 29 Jan 2018 11:31:25 +0000
+Subject: [PATCH] test/setddr: use Python 3
+
+All the other tests use Python 3, so this should to.
+---
+ test/set-ddr | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/set-ddr b/test/set-ddr
+index 5d061b95..33631f31 100755
+--- a/test/set-ddr
++++ b/test/set-ddr
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+ import sys
+ import dbus
+-- 
+2.11.0
index fd7ee15af1df3492f621459e9462a0e0b0cbf590..e57eaa77eb9882e6ae982d3932a62d2368a2ff79 100644 (file)
@@ -3,6 +3,7 @@ require ofono.inc
 SRC_URI  = "\
   ${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.xz \
   file://ofono \
+  file://use-python3.patch \
 "
 SRC_URI[md5sum] = "2a683ab8e98448ad8bc5dc9868d2893e"
 SRC_URI[sha256sum] = "8e34a6696c300c9841b55e8dff640bd3096e49f5dbe55bbebaa69a71676f687e"