]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: use new GTKDOC_DOCDIR and clean up
authorRoss Burton <ross.burton@intel.com>
Mon, 21 Jan 2013 12:15:34 +0000 (12:15 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jan 2013 12:44:07 +0000 (12:44 +0000)
Now that gtk-doc.bbclass supports overriding the documentation directory,
systemd can just inherit gtk-doc and all of the manual operations can be
removed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_196.bb

index ba42a40aa2b8ef57f2613eb9ec89aa6f44ceca6c..5242b5a8781306f0c1f9814a60e56d0ea38f8896 100644 (file)
@@ -8,14 +8,14 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \
 
 PROVIDES = "udev"
 
-DEPENDS = "xz kmod gtk-doc-stub-native docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers usbutils glib-2.0 libgcrypt"
+DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers usbutils glib-2.0 libgcrypt"
 DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 
 SERIAL_CONSOLE ?= "115200 /dev/ttyS0"
 
 SECTION = "base/shell"
 
-inherit useradd pkgconfig autotools perlnative
+inherit gtk-doc useradd pkgconfig autotools perlnative
 
 SRC_URI = "http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz \
            file://0001-Revert-systemd-analyze-use-argparse-instead-of-getop.patch \
@@ -47,6 +47,8 @@ CACHED_CONFIGUREVARS = "ac_cv_file__usr_share_pci_ids=no \
                         ac_cv_file__usr_share_hwdata_pci_ids=no \
                         ac_cv_file__usr_share_misc_pci_ids=yes"
 
+GTKDOC_DOCDIR = "${S}/docs/"
+
 # The gtk+ tools should get built as a separate recipe e.g. systemd-tools
 EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
                  --with-rootprefix=${base_prefix} \
@@ -59,7 +61,6 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
                  --disable-coredump \
                  --disable-introspection \
                  --with-pci-ids-path=/usr/share/misc \
-                 --disable-gtk-doc-html \
                  --disable-tcpwrap \
                  --enable-split-usr \
                  --disable-microhttpd \
@@ -69,12 +70,9 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
 # There's no docbook-xsl-native, so for the xsltproc check to false
 do_configure_prepend() {
        export CPP="${HOST_PREFIX}cpp ${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}"
-       sed -i /xsltproc/d configure.ac
 
        # we only have /home/root, not /root
        sed -i -e 's:=/root:=/home/root:g' units/*.service*
-
-       gtkdocize --docdir ${S}/docs/
 }
 
 do_install() {