]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-environment: Clean up the task structure to reduce manifest warnings
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Feb 2017 11:31:47 +0000 (11:31 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Feb 2017 18:02:07 +0000 (18:02 +0000)
This puts the dependencies on the correct task and removes pointless
noexec tasks allowing for a slightly cleaner task structure.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/meta-environment.bb

index 1128a56c1ebaa704f1437d25d1781a28c2e68d74..c7ac05d62a7aa84e404e8c6577372a84b7ed483a 100644 (file)
@@ -19,12 +19,10 @@ SDKTARGETSYSROOT = "${SDKPATH}/sysroots/${REAL_MULTIMACH_TARGET_SYS}"
 
 inherit cross-canadian
 
-# Need to ensure we have the virtual mappings and site files for all multtilib 
-# variants
-DEPENDS += "${@all_multilib_tune_values(d, 'TOOLCHAIN_NEED_CONFIGSITE_CACHE')}"
-
 do_generate_content[cleandirs] = "${SDK_OUTPUT}"
 do_generate_content[dirs] = "${SDK_OUTPUT}/${SDKPATH}"
+# Need to ensure we have the virtual mappings and site files for all multtilib variants
+do_generate_content[depends] = "${@oe.utils.build_depends_string(all_multilib_tune_values(d, 'TOOLCHAIN_NEED_CONFIGSITE_CACHE'), 'do_populate_sysroot')}"
 python do_generate_content() {
     # Handle multilibs in the SDK environment, siteconfig, etc files...
     localdata = bb.data.createCopy(d)
@@ -74,6 +72,6 @@ FILES_${PN}= " \
 deltask do_fetch
 deltask do_unpack
 deltask do_patch
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-do_populate_sysroot[noexec] = "1"
+deltask do_configure
+deltask do_compile
+deltask do_populate_sysroot