]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl-native_5.12.2.bb: Fix compliation on ubuntu 11.04-alpha
authorKhem Raj <raj.khem@gmail.com>
Fri, 18 Mar 2011 05:40:15 +0000 (22:40 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Mar 2011 12:21:16 +0000 (12:21 +0000)
Ubuntu has moved eglibc to /usr/lib/${arch}-linux-gnu and
/lib/${arch}-linux-gnu so we need that to be added to glibpth in
Configure.

Currently we set LD=ld in environment for recipes inheriting native
class. This overrides the LD settings in the Makefiles of perl and
it tries to link by calling ld which does not work since its using
-l<x> on commandline and ubuntu linker seems not to look into
the new location for these libraries. Its better to use gcc for linking
here anyway

[With tweak from Tom Rini to use CCLD, not LD]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-devtools/perl/files/Configure-multilib.patch
meta/recipes-devtools/perl/perl-native_5.12.2.bb

index d3948a92c0a601064c6606950faeaa7005e16040..b561b6ab6fb63d6191e7ff57cf38c7b5b09c6716 100644 (file)
@@ -1,11 +1,15 @@
---- perl-5.8.7/Configure.orig  2006-01-30 10:50:04.000000000 +0000
-+++ perl-5.8.7/Configure       2006-01-30 10:51:18.000000000 +0000
-@@ -1240,7 +1240,7 @@
+Index: perl-5.12.2/Configure
+===================================================================
+--- perl-5.12.2.orig/Configure
++++ perl-5.12.2/Configure
+@@ -1316,8 +1316,9 @@ loclibpth="/usr/local/lib /opt/local/lib
  loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
  
  : general looking path for locating libraries
 -glibpth="/lib /usr/lib $xlibpth"
 +glibpth="/lib /usr/lib /lib64 /usr/lib64 $xlibpth"
  glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
++test -f /usr/lib/`uname -m`-linux-gnu/libc.so && glibpth="/usr/lib/`uname -m`-linux-gnu $glibpth"
  test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
  test -f /shlib/libc.so     && glibpth="/shlib $glibpth"
+ test -d /usr/lib64         && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"
index 9af7b06e08632df527e3d2381e8b465a9f9c304e..c9882a9101df9894ed8791e531542a59a63e5036 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "libs"
 LICENSE = "Artistic|GPL"
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                    file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
-PR = "r7"
+PR = "r8"
 
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                     file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
@@ -28,6 +28,8 @@ S = "${WORKDIR}/perl-${PV}"
 
 inherit native
 
+export LD="${CCLD}"
+
 do_configure () {
        ./Configure \
                -Dcc="${CC}" \