]> code.ossystems Code Review - openembedded-core.git/commitdiff
net-tools: Place package content as per bitbake environment.
authorAmarnath Valluri <amarnath.valluri@intel.com>
Wed, 8 Feb 2017 09:21:52 +0000 (11:21 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Mar 2017 22:43:01 +0000 (22:43 +0000)
net-tools Makefile was hardcoded sbin, bin installation paths to /bin and /sbin
respectively.  This change moves the installed files to appropriate location as
per configured bitbake environment.

This might be solved much better way by patching Makefile, but that causing
build issues, as net-tools recipe is using pre-generated config.{h/status}.

Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com>
meta/recipes-extended/net-tools/net-tools_1.60-26.bb

index 99a42359b81726f04399d74232fa21fd39933643..be267351e3cdabc411d05225034bc4a536266351 100644 (file)
@@ -93,6 +93,17 @@ do_install() {
        unset CFLAGS
        unset LDFLAGS
        oe_runmake 'BASEDIR=${D}' install
+
+       if [ "${base_bindir}" != "/bin" ]; then
+               mkdir -p ${D}/${base_bindir}
+               mv ${D}/bin/* ${D}/${base_bindir}/
+               rmdir ${D}/bin
+       fi
+       if [ "${base_sbindir}" != "/sbin" ]; then
+               mkdir ${D}/${base_sbindir}
+               mv ${D}/sbin/* ${D}/${base_sbindir}/
+               rmdir ${D}/sbin
+       fi
 }
 
 inherit update-alternatives