]> code.ossystems Code Review - openembedded-core.git/commitdiff
ubootchart: delete ubootchart recipe
authorMax Eliaser <max.eliaser@intel.com>
Thu, 7 Aug 2014 17:47:48 +0000 (10:47 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Aug 2014 09:46:59 +0000 (10:46 +0100)
The Ubootchart recipe had known issues. Ubootchart itself is no longer updated
upstream. Ubootchart is also now redundant with Bootchart2.

If people still want ubootchart around, it can be moved to meta-oe.

Ubootchart removed as part of the solution to [YOCTO #5893].

Signed-off-by: Max Eliaser <max.eliaser@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/ubootchart/files/sysvinit.patch [deleted file]
meta/recipes-devtools/ubootchart/files/ubootchart-stop [deleted file]
meta/recipes-devtools/ubootchart/files/ubootchart.desktop [deleted file]
meta/recipes-devtools/ubootchart/ubootchart_svn.bb [deleted file]

diff --git a/meta/recipes-devtools/ubootchart/files/sysvinit.patch b/meta/recipes-devtools/ubootchart/files/sysvinit.patch
deleted file mode 100644 (file)
index fc82ed8..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Upstream-Status: Inappropriate [distribution]
-
-Index: ubootchart.conf
-===================================================================
---- ubootchart.conf    (revision 9)
-+++ ubootchart.conf    (working copy)
-@@ -1,6 +1,6 @@
- # If you want to chain on and run somthing other than /sbin/init...
--export init_prog=/sbin/init
-+export init_prog=/sbin/init.sysvinit
- # On startup ubootchart will mount a tmpfs filesystem at this
- # location and chdir here. This is only used for the logging of
diff --git a/meta/recipes-devtools/ubootchart/files/ubootchart-stop b/meta/recipes-devtools/ubootchart/files/ubootchart-stop
deleted file mode 100644 (file)
index 3444069..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#! /bin/sh
-
-kill -USR1 $(pidof ubootchartd_bin)
diff --git a/meta/recipes-devtools/ubootchart/files/ubootchart.desktop b/meta/recipes-devtools/ubootchart/files/ubootchart.desktop
deleted file mode 100644 (file)
index 5552b3b..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=/sbin/ubootchart-stop
-Name=Stop Bootchart
-Type=Application
-Categories=Programming;
diff --git a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
deleted file mode 100644 (file)
index b13755e..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-SUMMARY = "A boot profiling tool"
-HOMEPAGE = "http://code.google.com/p/ubootchart/"
-LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
-SRCREV = "12"
-PV = "0.0+r${SRCPV}"
-PR = "r6"
-
-#RRECOMMENDS_${PN} = "acct"
-
-SRC_URI = "svn://ubootchart.googlecode.com/svn/;protocol=http;module=trunk \
-        file://sysvinit.patch;striplevel=0 \
-        file://ubootchart-stop \
-        file://ubootchart.desktop"
-
-S = "${WORKDIR}/trunk"
-
-inherit update-alternatives
-
-ALTERNATIVE_${PN} = "init"
-ALTERNATIVE_TARGET[init] = "${base_sbindir}/ubootchartd"
-ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
-ALTERNATIVE_PRIORITY = "70"
-
-do_compile() {
-        ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
-}
-
-do_install() {
-        install -m 0755 -d ${D}${base_sbindir} ${D}${sysconfdir}/ubootchart ${D}${datadir}/applications
-        install -m 0755 ${S}/ubootchartd_bin ${D}${base_sbindir}
-        install -m 0755 ${S}/ubootchartd ${D}${base_sbindir}
-        install -m 0644 ${S}/ubootchart.conf ${D}${sysconfdir}/ubootchart
-        install -m 0755 ${S}/start.sh ${D}${sysconfdir}/ubootchart
-        install -m 0755 ${S}/finish.sh ${D}${sysconfdir}/ubootchart
-        
-        install -m 0755 ${WORKDIR}/ubootchart-stop ${D}${base_sbindir}
-        install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}${datadir}/applications
-}