]> code.ossystems Code Review - openembedded-core.git/commitdiff
wayland: fix upstream release checking
authorRoss Burton <ross.burton@intel.com>
Fri, 8 Jun 2018 13:50:27 +0000 (14:50 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 15 Jun 2018 10:09:40 +0000 (11:09 +0100)
Wayland has moved to GitLab with the result that /releases/ no longer returns a
directory listing, so the upgrade detection doesn't work.

The upgrade detection can scan releases.html just as well, so tell it to look
there.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/wayland/wayland-protocols_1.14.bb
meta/recipes-graphics/wayland/wayland_1.15.0.bb
meta/recipes-graphics/wayland/weston_4.0.0.bb

index 3393a2c797dfbb449af4c05b200a5d49b5b81cd2..873fcf1c28269ad552671927dd26eef67565b9df 100644 (file)
@@ -14,6 +14,8 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
 SRC_URI[md5sum] = "5d32eaf0f5d6b7da7f5ad0959e2551e6"
 SRC_URI[sha256sum] = "9648896b2462b49b15a69b60f44656593c170c0e73121c890eb16d0c1d9376f6"
 
+UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
+
 inherit allarch autotools pkgconfig
 
 PACKAGES = "${PN}"
index 788105bff8e8c32e886ad59558d1549a77f84174..d037dc46542cf82402a14e385e0df11bccefd101 100644 (file)
@@ -18,6 +18,8 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
 SRC_URI[md5sum] = "b7393c17fdce9a8d383edab656c92fd2"
 SRC_URI[sha256sum] = "eb3fbebb8559d56a80ad3753ec3db800f587329067962dbf65e14488b4b7aeb0"
 
+UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
+
 inherit autotools pkgconfig
 
 EXTRA_OECONF = "--disable-documentation --with-host-scanner"
index 7dfca7fc633a474b8ef786d22dffe3224cd68627..e78b0d919495c31b4b780088e83a1c68e482f48a 100644 (file)
@@ -15,6 +15,8 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
 SRC_URI[md5sum] = "33709aa4d5916f89643fca0fc0064b39"
 SRC_URI[sha256sum] = "a0fc0ae7ef83dfbed12abfe9b8096a24a7dd00705e86fa0db1e619ded18b4b58"
 
+UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
+
 inherit autotools pkgconfig useradd distro_features_check
 # depends on virtual/egl
 REQUIRED_DISTRO_FEATURES = "opengl"