]> code.ossystems Code Review - openembedded-core.git/commitdiff
readline: exclude autoheader from autoreconf
authorRoss Burton <ross.burton@intel.com>
Wed, 28 May 2014 11:56:24 +0000 (12:56 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 May 2014 09:32:29 +0000 (10:32 +0100)
readline ships a hand-maintained config.h, instead of letting autoheader
generate one from configure.ac.  The required arguments to AC_DEFINE are not in
configure.ac so autoheader will produce warnings and the generated code will not
behave as expected.

Solve this by excluding autoheader from autoreconf, so the upstream config.h.in
is used.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/readline/readline.inc

index c33e91a55002ff9fdc2be64e03a2d32314452f42..2c5ad002f7917fa7e116e9194b858bd2cfca32ce 100644 (file)
@@ -21,6 +21,8 @@ S = "${WORKDIR}/${BPN}-${PV}"
 
 inherit autotools texinfo
 
+EXTRA_AUTORECONF += "--exclude=autoheader"
+
 LEAD_SONAME = "libreadline.so"
 
 do_configure_prepend () {