]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Fix writev syscall null value handling, fixes glibc LC_CTYPE errors during...
authorRichard Purdie <richard@openedhand.com>
Sun, 3 Feb 2008 00:03:07 +0000 (00:03 +0000)
committerRichard Purdie <richard@openedhand.com>
Sun, 3 Feb 2008 00:03:07 +0000 (00:03 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3661 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/qemu/qemu-0.9.1/writev_fix.patch [new file with mode: 0644]
meta/packages/qemu/qemu_0.9.1.bb

diff --git a/meta/packages/qemu/qemu-0.9.1/writev_fix.patch b/meta/packages/qemu/qemu-0.9.1/writev_fix.patch
new file mode 100644 (file)
index 0000000..e0ed4af
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ linux-user/syscall.c |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: qemu-0.9.1/linux-user/syscall.c
+===================================================================
+--- qemu-0.9.1.orig/linux-user/syscall.c       2008-02-03 00:00:00.000000000 +0000
++++ qemu-0.9.1/linux-user/syscall.c    2008-02-03 00:00:38.000000000 +0000
+@@ -1048,7 +1048,7 @@ static abi_long lock_iovec(int type, str
+         base = tswapl(target_vec[i].iov_base);
+         vec[i].iov_len = tswapl(target_vec[i].iov_len);
+         vec[i].iov_base = lock_user(type, base, vec[i].iov_len, copy);
+-      if (!vec[i].iov_base) 
++      if (!vec[i].iov_base && vec[i].iov_len) 
+             goto fail;
+     }
+     unlock_user (target_vec, target_addr, 0);
index 59aa55bbed160d46fcbf1070a3b596e7bd3fbf35..1a34d4d73b353524349c8a97b2f1122933ef515c 100644 (file)
@@ -1,6 +1,6 @@
 LICENSE = "GPL"
 DEPENDS = "zlib"
-PR = "r4"
+PR = "r5"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
 FILESDIR = "${WORKDIR}"
@@ -31,6 +31,7 @@ SRC_URI = "\
     file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
     file://workaround_bad_futex_headers.patch;patch=1 \
     file://fix_segfault.patch;patch=1 \
+    file://writev_fix.patch;patch=1 \
     file://configure_symlinkpath_fix.patch;patch=1 \
     file://disable-error-in-configure.patch;patch=1"