]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-nodm: Run the script in the background so if xtscal locks, the rest of the...
authorRichard Purdie <richard@openedhand.com>
Thu, 22 Jun 2006 09:28:53 +0000 (09:28 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 22 Jun 2006 09:28:53 +0000 (09:28 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@492 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/xserver-kdrive-common/xserver-nodm-init.bb
openembedded/packages/xserver-kdrive-common/xserver-nodm-init/xserver-nodm

index 8b79b4bdd2be55501ce496e913d96cdd60982b65..5dff889184cb6947c53ad1026693b024eab26c08 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
 LICENSE = "GPL"
 SECTION = "x11"
 PRIORITY = "optional"
-PR = "r3"
+PR = "r6"
 
 SRC_URI = "file://xserver-nodm"
 S = ${WORKDIR}
index 1c6f742a11b98600c0e4bf79903eae70f619396b..eeab55a71ad40d5a5e0b0c7dd0c7d58857d5d425 100755 (executable)
@@ -8,12 +8,19 @@ killproc() {            # kill the named process(es)
         [ "$pid" != "" ] && kill $pid
 }
 
-. /etc/profile
+
 
 case "$1" in
   start)
+    # We don't want this script to block the rest of the boot process
+    if [ "$2" != "background" ]; then
+      $0 $1 background &
+    else
+       . /etc/profile
+
        echo "Starting Xserver"
        /etc/X11/Xserver &
+       
        export DISPLAY=:0
               
        while [ ! -z $TSLIB_TSDEVICE ] && [ ! -f /etc/pointercal ]
@@ -22,6 +29,7 @@ case "$1" in
        done
 
        /etc/X11/Xsession &
+    fi 
   ;;
 
   stop)