]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib-2.0: Add nativesdk depends for libffi
authorSaul Wold <sgw@linux.intel.com>
Sat, 15 Oct 2011 00:47:47 +0000 (17:47 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Oct 2011 12:32:24 +0000 (13:32 +0100)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/glib-2.0/glib-2.0_2.30.0.bb
meta/recipes-gnome/libffi/libffi_3.0.9.bb

index 8fc6c8125a88bc4de3598ee1609d22eb38f36926..566355d9deff490f696b2bcf52aed04b16a8a114 100644 (file)
@@ -1,10 +1,11 @@
 require glib.inc
 
-PR = "r1"
+PR = "r2"
 PE = "1"
 
 DEPENDS += "libffi python-argparse-native"
 DEPENDS_virtclass-native += "libffi-native python-argparse-native"
+DEPENDS_virtclass-nativesdk += "libffi-nativesdk python-argparse-native zlib-nativesdk"
 
 SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
 
index 0ea2284160a51387838185764c05d7b3faa219a2..fae1adb613c2fdffb527451916e01e7d90796c8a 100644 (file)
@@ -7,7 +7,7 @@ library really only provides the lowest, machine dependent layer of a fully feat
 A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
 SRC_URI = "ftp://sourceware.org/pub/libffi/${BPN}-${PV}.tar.gz"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI[md5sum] = "1f300a7a7f975d4046f51c3022fa5ff1"
 SRC_URI[sha256sum] = "589d25152318bc780cd8919b14670793f4971d9838dab46ed38c32b3ee92c452"
@@ -16,4 +16,4 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fa09cb778aaba64dc9eac37ab7e4e5d8"
 inherit autotools
 
 FILES_${PN}-dev += "${libdir}/libffi-${PV}"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"