]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Update for python 2.6
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 10 Dec 2009 14:15:01 +0000 (14:15 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 10 Dec 2009 14:15:01 +0000 (14:15 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/rpm/rpm_4.4.2.3.bb

index cd1c42888ba371473d4b34aba2f7cbbbe31cdd09..6efa87bb00d011ae58a4116414491c5f541c2b60 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "The RPM Package Manager."
 HOMEPAGE = "http://rpm.org/"
 LICENSE = "LGPL GPL"
 DEPENDS = "zlib beecrypt file popt python"
-PR = "r15"
+PR = "r16"
 
 SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
            file://external-tools.patch;patch=1 \
@@ -102,6 +102,7 @@ do_install_append () {
 def rpm_python_version(d):
        import os, bb
        staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
+       if os.path.exists( "%s/python2.6" % staging_incdir ): return "2.6"
        if os.path.exists( "%s/python2.5" % staging_incdir ): return "2.5"
        if os.path.exists( "%s/python2.4" % staging_incdir ): return "2.4"
        if os.path.exists( "%s/python2.3" % staging_incdir ): return "2.3"