]> code.ossystems Code Review - openembedded-core.git/commitdiff
v86d: compile against userspace safe kernel headers
authorBruce Ashfield <bruce.ashfield@windriver.com>
Sat, 16 Feb 2013 04:17:51 +0000 (23:17 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 1 Mar 2013 12:57:21 +0000 (12:57 +0000)
v86d was building directly against the staged kernel in the target
sysroot. This has been fine in the past, but with recent (3.7) changes
to user headers into the "uapi" include structure, there are no longer

Without the preprocesor protection, v86d fails to build against any
kernel with uapi header files.

v86d doesn't actually need the whole kernel tree, the exported headers
are enough to build a working binary. This change sets the v86d variable
to ${STAGING_DIR_HOST}/usr, and once the v86d build adds "include" to the
end of KDIR, we have a valid include path to the target sysroot headers.

This also works for pre-uapi kernel headers, so the change is safe for
most (if not all) kernel's with properly exported headers.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-bsp/v86d/v86d_0.1.10.bb

index 51829a3edb12f0fd0e63854be2129f4fdd7c9ef8..2dbfbb579a8c6063b8df7a14474cf57576e56e31 100644 (file)
@@ -27,7 +27,7 @@ do_configure () {
 }
 
 do_compile () {
-       KDIR="${STAGING_KERNEL_DIR}" make
+       KDIR="${STAGING_DIR_HOST}/usr" make
 }
 
 do_install () {