]> code.ossystems Code Review - openembedded-core.git/commitdiff
Drop darwin8/darwin9 usage
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Aug 2013 10:40:53 +0000 (10:40 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Aug 2013 17:30:07 +0000 (18:30 +0100)
There were darwin8/darwin9 overrides spinkled in the code from times gone
by. Lets settle on the darwin override and remove the others since its pointless
duplication. We always inject darwin into OVERRIDES if needed in the darwin8/9
cases.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/bitbake.conf
meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb

index 679fc9e6e27fe68a66e780a3151f17a736297829..8f98a93dc54aa3ae23402ef88f89f6f4024df35b 100644 (file)
@@ -260,16 +260,12 @@ MULTI_PROVIDER_WHITELIST = "virtual/libintl virtual/libintl-native virtual/nativ
 
 SOLIBS = ".so.*"
 SOLIBS_darwin = ".dylib"
-SOLIBS_darwin8 = ".dylib"
-SOLIBS_darwin9 = ".dylib"
 
 SOLIBSDEV = ".so"
 # Due to the ordering of PACKAGES and the naming of the dev symlinks on darwin,
 # we can't make the symlinks end up in the -dev packages easily at this point. This hack
 # at least means builds aren't completely broken and symlinks don't take up much space.
 SOLIBSDEV_darwin = ".dylibbroken"
-SOLIBSDEV_darwin8 = ".dylibbroken"
-SOLIBSDEV_darwin9 = ".dylibbroken"
 
 PACKAGE_BEFORE_PN ?= ""
 PACKAGES = "${PN}-dbg ${PN}-staticdev ${PN}-dev ${PN}-doc ${PN}-locale ${PACKAGE_BEFORE_PN} ${PN}"
index 63fea288f8b019c0d0a41322fcf3171624c37420..84fb95d3938fe143e2538522cc2e366bf07cb364 100644 (file)
@@ -22,7 +22,7 @@ RDEPENDS_${PN} = "\
     nativesdk-automake \
     "
 
-RDEPENDS_${PN}_darwin8 = "\
+RDEPENDS_${PN}_darwin = "\
     odcctools-cross-canadian \
     llvm-cross-canadian \
     nativesdk-pkgconfig \
index d2312685aa441883a9d412b2261876b4f56a297d..928a0cd6883aac1d09bfbf8b26d70951dd3613fe 100644 (file)
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "b984aaf1fe888d6a4cf8c2e8d397207879599b5368f1d33232c1ec9d68
 
 EXTRA_OECONF += "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-elf-shlibs --disable-libuuid --disable-uuidd"
 EXTRA_OECONF_darwin = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-bsd-shlibs"
-EXTRA_OECONF_darwin8 = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-bsd-shlibs"
 
 do_configure_prepend () {
        cp ${WORKDIR}/acinclude.m4 ${S}/