]> code.ossystems Code Review - openembedded-core.git/commitdiff
blktrace: essentially rework the recipe, obey LDFLAGS
authorFahad Usman <fahad_usman@mentor.com>
Thu, 20 Dec 2012 12:40:32 +0000 (17:40 +0500)
committerSaul Wold <sgw@linux.intel.com>
Tue, 25 Dec 2012 22:00:20 +0000 (14:00 -0800)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
the patch was imported from meta-mentor layer on yoctoproject git server
http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id
aed463414e2e2bf8ca44ba54ee5973e7ed599e57

Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch [deleted file]
meta/recipes-kernel/blktrace/blktrace/ldflags.patch [new file with mode: 0644]
meta/recipes-kernel/blktrace/blktrace_git.bb

diff --git a/meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch b/meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch
deleted file mode 100644 (file)
index c0f5fb0..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile  2010-11-22 11:20:14.303472770 -0600
-+++ git/Makefile       2010-11-22 14:11:19.152635423 -0600
-@@ -1,5 +1,3 @@
--CC    = gcc
--CFLAGS        = -Wall -O2 -g -W
- ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
- PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
- LIBS  = -lpthread
-@@ -11,13 +9,13 @@
- all: $(ALL)
- btt/btt:
--      $(MAKE) -C btt
-+      CC="${CC}" CFLAGS="${CFLAGS}" $(MAKE) -C btt CC="${CC}" CFLAGS="${CFLAGS}"
- btreplay/btrecord:
--      $(MAKE) -C btreplay
-+      CC="${CC}" CFLAGS="${CFLAGS}" $(MAKE) -C btreplay CC="${CC}" CFLAGS="${CFLAGS}" btrecord
- btreplay/btreplay:
--      $(MAKE) -C btreplay
-+      CC="${CC}" CFLAGS="${CFLAGS}" $(MAKE) -C btreplay CC="${CC}" CFLAGS="${CFLAGS}" btreplay
- %.o: %.c
-       $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-Index: git/btreplay/Makefile
-===================================================================
---- git.orig/btreplay/Makefile 2010-11-22 11:21:12.972679035 -0600
-+++ git/btreplay/Makefile      2010-11-22 14:07:01.492839945 -0600
-@@ -5,8 +5,6 @@
- #     NDEBUG          - Defined: no asserts, Undefined: asserts
- #
--CC    = gcc
--CFLAGS        = -Wall -W -O2 -g
- INCS  = -I. -I.. -I../btt
- OCFLAGS       = -UCOUNT_IOS -UDEBUG -DNDEBUG
- XCFLAGS       = -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-Index: git/btt/Makefile
-===================================================================
---- git.orig/btt/Makefile      2010-11-22 11:21:01.833758370 -0600
-+++ git/btt/Makefile   2010-11-22 14:07:15.783258253 -0600
-@@ -5,8 +5,6 @@
- #     NDEBUG          - Defined: no asserts, Undefined: asserts
- #
--CC    = gcc
--CFLAGS        = -Wall -W -O2 -g
- INCS  = -I. -I..
- XCFLAGS       = -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
- override CFLAGS += $(INCS) $(XCFLAGS)
diff --git a/meta/recipes-kernel/blktrace/blktrace/ldflags.patch b/meta/recipes-kernel/blktrace/blktrace/ldflags.patch
new file mode 100644 (file)
index 0000000..b9c7c20
--- /dev/null
@@ -0,0 +1,89 @@
+blktrace: obey LDFLAGS
+
+Upstream-Status: Pending
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+
+the patch was imported from meta-mentor layer on yoctoproject git server
+http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id
+aed463414e2e2bf8ca44ba54ee5973e7ed599e57
+
+Signed-off-by: Fahad Usman <fahad_usman@mentor.com>
+---
+ Makefile          |   11 ++++++-----
+ btreplay/Makefile |    3 ++-
+ btt/Makefile      |    3 ++-
+ 3 files changed, 10 insertions(+), 7 deletions(-)
+
+--- git.orig/Makefile
++++ git/Makefile
+@@ -1,5 +1,6 @@
+ CC    = gcc
+ CFLAGS        = -Wall -O2 -g -W
++LDFLAGS =
+ ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+ PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
+ LIBS  = -lpthread
+@@ -23,19 +24,19 @@ btreplay/btreplay:
+       $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+ blkparse: blkparse.o blkparse_fmt.o rbtree.o act_mask.o
+-      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LDFLAGS)
+ blktrace: blktrace.o act_mask.o
+-      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
+ verify_blkparse: verify_blkparse.o
+-      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LDFLAGS)
+ blkrawverify: blkrawverify.o
+-      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LDFLAGS)
+ blkiomon: blkiomon.o rbtree.o
+-      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
++      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt $(LDFLAGS)
+ $(PROGS): | depend
+--- git.orig/btreplay/Makefile
++++ git/btreplay/Makefile
+@@ -7,6 +7,7 @@
+ CC    = gcc
+ CFLAGS        = -Wall -W -O2 -g
++LDFLAGS =
+ INCS  = -I. -I.. -I../btt
+ OCFLAGS       = -UCOUNT_IOS -UDEBUG -DNDEBUG
+ XCFLAGS       = -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+@@ -35,7 +36,7 @@ btrecord: btrecord.o
+       $(CC) $(CFLAGS) -o $@ $(filter %.o,$^)
+ btreplay: btreplay.o
+-      $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++      $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
+ depend:
+       @$(CC) -MM $(CFLAGS) *.c 1> .depend
+--- git.orig/btt/Makefile
++++ git/btt/Makefile
+@@ -7,6 +7,7 @@
+ CC    = gcc
+ CFLAGS        = -Wall -W -O2 -g
++LDFLAGS =
+ INCS  = -I. -I..
+ XCFLAGS       = -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+ override CFLAGS += $(INCS) $(XCFLAGS)
+@@ -38,7 +39,7 @@ clean: docsclean
+       $(CC) $(CFLAGS) -c -o $*.o $<
+ btt: $(OBJS)
+-      $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++      $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
+ ifneq ($(wildcard .depend),)
+ include .depend
index dbc07c5a977e5fd9262d2d5c43187141d7efa725..80cb14c82e80bdfbd6dbf8e3b82868050c550056 100644 (file)
@@ -6,19 +6,17 @@ DEPENDS = "libaio"
 
 SRCREV = "d6918c8832793b4205ed3bfede78c2f915c23385"
 
-PR = "r4"
+PR = "r5"
 PV = "1.0.5+git${SRCPV}"
 
 SRC_URI = "git://git.kernel.dk/blktrace.git;protocol=git \
-           file://blktrace-makefile.patch"
+           file://ldflags.patch"
 
 S = "${WORKDIR}/git"
 
-do_compile() { 
-       oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" prefix=${prefix}
-}
-
-do_install() {
-       oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" \
-                   prefix=${prefix} DESTDIR=${D} install
-}
+EXTRA_OEMAKE = "\
+    'CC=${CC}' \
+    'CFLAGS=${CFLAGS}' \
+    'LDFLAGS=${LDFLAGS}' \
+"
+PARALLEL_MAKE = ""