]> code.ossystems Code Review - openembedded-core.git/commitdiff
iproute2: pass CFLAGS to Makefile\
authorJoe Slater <jslater@windriver.com>
Thu, 15 Nov 2012 17:47:49 +0000 (09:47 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 24 Nov 2012 15:12:07 +0000 (15:12 +0000)
Makefile computes CFLAGS, but we can see that our
defaults get included by using CCOPTS to pass them
to make.

Upstream-Status: Pending

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/iproute2/iproute2_3.5.1.bb

index c1e9bd3a86dd223101eb223628df2f02dad6e2fb..3d402cffcd452652e099001614ea2865e2085db6 100644 (file)
@@ -1,9 +1,13 @@
 require iproute2.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BPN}-${PV}.tar.xz \
            file://configure-cross.patch"
 
 SRC_URI[md5sum] = "d4425b44edd5eacd6099e672e4baacbf"
 SRC_URI[sha256sum] = "36f2674e5436289f3ccfb0a58707aca9dcfa295d06afc36d2117674508f5ef72"
+
+# CFLAGS are computed in Makefile and reference CCOPTS
+#
+EXTRA_OEMAKE_append = " CCOPTS='${CFLAGS}'"