]> code.ossystems Code Review - openembedded-core.git/commitdiff
layer.conf: Add LAYERVERSION and LAYERDEPENDS
authorwenzong.fan@windriver.com <wenzong.fan@windriver.com>
Mon, 11 Mar 2013 08:06:02 +0000 (16:06 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:17:38 +0000 (13:17 +0000)
Add LAYERVERSION and LAYERDEPENDS to following oe-core layers:

    meta-hob, meta-skeleton

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta-hob/conf/layer.conf
meta-skeleton/conf/layer.conf

index 5f5eb8218c8f4ed16374f293ff5e65d6d7c61bc8..ea977e2cc3a3afa5e4a92648d6eca49191d1dc68 100644 (file)
@@ -7,3 +7,9 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb"
 BBFILE_COLLECTIONS += "hob"
 BBFILE_PATTERN_hob := "^${LAYERDIR}/"
 BBFILE_PRIORITY_hob = "1"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_hob = "1"
+
+LAYERDEPENDS_hob = "core"
index edb31dd89a30b06bf15e97664a986522d629d835..4cf476711d2d9fd767e80737310e9950326516b7 100644 (file)
@@ -8,3 +8,8 @@ BBFILE_COLLECTIONS += "skeleton"
 BBFILE_PATTERN_skeleton := "^${LAYERDIR}/"
 BBFILE_PRIORITY_skeleton = "1"
 
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_skeleton = "1"
+
+LAYERDEPENDS_skeleton = "core"