]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-cython: upgrade 0.29.24 -> 0.29.25
authorwangmy <wangmy@fujitsu.com>
Mon, 13 Dec 2021 13:16:11 +0000 (21:16 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Dec 2021 22:45:39 +0000 (22:45 +0000)
Changelog:
================
Bugs fixed
----------
* Several incompatibilities with CPython 3.11 were resolved.
  (Github issues #4411, #4414, #4415, #4416, #4420, #4428, #4473, #4479, #4480)

* Some C compiler warnings were resolved.
  (Github issue #4439)

* C++ "std::move()" should only be used automatically in MSVC versions that support it.
  (Github issue #4191)

 * The "Py_hash_t" type failed to accept arbitrary "index" values.
   (Github issue #2752)

* Avoid copying unaligned 16-bit values since some platforms require them to be aligned.
  Use memcpy() instead to let the C compiler decide how to do it.
  (Github issue #4343)

* Cython crashed on invalid truthiness tests on C++ types without "operator bool".
  (Github issue #4348)

* The declaration of "PyUnicode_CompareWithASCIIString()" in "cpython.unicode" was incorrect.
  (Github issue #4344)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-cython.inc
meta/recipes-devtools/python/python3-cython_0.29.25.bb [moved from meta/recipes-devtools/python/python3-cython_0.29.24.bb with 100% similarity]

index 5a8ec2a0ff1a8c531f74cf52d65030f63b2df2d7..93d6fdf13ba063d7c4415758fb22dbc94651c4d3 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
 PYPI_PACKAGE = "Cython"
 BBCLASSEXTEND = "native nativesdk"
 
-SRC_URI[sha256sum] = "cdf04d07c3600860e8c2ebaad4e8f52ac3feb212453c1764a49ac08c827e8443"
+SRC_URI[sha256sum] = "a87cbe3756e7c464acf3e9420d8741e62d3b2eace0846cb39f664ad378aab284"
 UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
 
 inherit pypi