]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball: Add an ld.so.conf for nativesdk-binutils
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Jan 2020 17:15:03 +0000 (17:15 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Sep 2020 23:11:53 +0000 (00:11 +0100)
We need to search our own libdirs, then fall back to the system ones as our
customised dynamic loader will. Have ld.so.conf reflect that.

This ensures that binutils finds libraries here when linking too.

(From OE-Core rev: ab729c362684474a8346e5256d636200826feb47)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/buildtools-tarball.bb

index 91df6f1ae9f60c4ff778399c5cf4b1a40f5e0402..eca9f1c0e1fa92e4027c30b77974aa59122cf32f 100644 (file)
@@ -73,6 +73,10 @@ create_sdk_files_append () {
 
        echo 'export GIT_SSL_CAINFO="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
 
+       mkdir -p ${SDK_OUTPUT}/${SDKPATHNATIVE}${sysconfdir}/
+       echo '${SDKPATHNATIVE}${libdir}
+${SDKPATHNATIVE}${base_libdir}
+include /etc/ld.so.conf' > ${SDK_OUTPUT}/${SDKPATHNATIVE}${sysconfdir}/ld.so.conf
        if [ "${SDKMACHINE}" = "i686" ]; then
                echo 'export NO32LIBS="0"' >>$script
                echo 'echo "$BB_ENV_EXTRAWHITE" | grep -q "NO32LIBS"' >>$script