]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-kernel-dev: Define a correct subset of TEST_SUITES to run for this image
authorSaul Wold <sgw@linux.intel.com>
Tue, 30 Jun 2015 22:48:02 +0000 (15:48 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 7 Jul 2015 22:57:12 +0000 (23:57 +0100)
Since this image can be built with both poky and poky-lsb, ensure the correct
tests are run in both cases, the auto detection does not quite work right in the
poky-lsb case since not all the Posix cmdline utilites are added. Add connman and
connman test for network sanity

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/images/core-image-kernel-dev.bb

index e1aa71a79fb94236947c445cb893b5ae3367056a..6b636ed080b71eaae541b3ae7d4e925cbc8d183f 100644 (file)
@@ -4,7 +4,7 @@ sensitive to kernel updates and version changes"
 # Could also be core-image-basic, but we'll keep this small for now
 require recipes-core/images/core-image-minimal.bb
 
-KERNEL_DEV_UTILS ?= "dropbear"
+KERNEL_DEV_UTILS ?= "dropbear connman"
 KERNEL_DEV_TOOLS ?= "packagegroup-core-tools-profile packagegroup-core-buildessential kernel-devsrc"
 KERNEL_DEV_MODULE ?= "kernel-modules"
 
@@ -15,3 +15,6 @@ CORE_IMAGE_EXTRA_INSTALL += "${KERNEL_DEV_MODULE} \
 
 # We need extra space for things like kernel builds, etc.
 IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 3000000"
+
+# Let's define our own subset to test, we can later add a on-target kernel build even!
+DEFAULT_TEST_SUITES = "ping ssh df connman syslog scp date dmesg parselogs"