]> code.ossystems Code Review - openembedded-core.git/commitdiff
Make setdevenv automagically setup local.conf if it dont exist
authorMatthew Allum <mallum@openedhand.com>
Wed, 31 Aug 2005 11:21:44 +0000 (11:21 +0000)
committerMatthew Allum <mallum@openedhand.com>
Wed, 31 Aug 2005 11:21:44 +0000 (11:21 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@4 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/conf/local.conf.sample
setdevenv

index 7a7afb427724622108ded9edfd98d98da0416fc7..489b0deb19e1ae79d5462959a571c6fe6d67e985 100644 (file)
 # expansion.  Stuff like starting with ${HOME} or ${TOPDIR} is ok).
 
 # Use this to specify where BitBake should place the downloaded sources into
-DL_DIR = "${HOME}/sources"
+DL_DIR = "POKYROOT/sources"
 
 # Delete the line below. Then specify which .bb files to consider for
 # your build. Typically this will be something like BBFILES = "/path/to/openembedded/packages/*/*.bb"
-BBFILES := "${@bb.fatal('Edit your conf/local.conf: BBFILES')}"
+#BBFILES := "${@bb.fatal('Edit your conf/local.conf: BBFILES')}"
+BBFILES := "POKYROOT/openembedded/packages/*/*.bb"
 
 # Use the BBMASK below to instruct BitBake to _NOT_ consider some .bb files
 # This is a regulary expression, so be sure to get your parenthesis balanced.
@@ -119,4 +120,4 @@ BBINCLUDELOGS = "yes"
 CVS_TARBALL_STASH = "http://www.oesources.org/source/current/"
 
 # EDIT THIS FILE and then remove the line below before using!
-REMOVE_THIS_LINE:="${@oe.fatal('Read the comments in your conf/local.conf')}"
+#REMOVE_THIS_LINE:="${@oe.fatal('Read the comments in your conf/local.conf')}"
index c6945ca16acc323089f0e99ac144a54b90dbe37f..0c3c572fe04434ef75a6af28327fba72c152d46e 100755 (executable)
--- a/setdevenv
+++ b/setdevenv
@@ -4,7 +4,7 @@
 # Change this to the location of this file.
 # Also update the locations at the top of conf/local.conf
 #
-OEROOT=/usr/ohoe/
+OEROOT=`pwd`
 
 BBDIR=$OEROOT/bitbake/
 PKGDIR=$OEROOT/openembedded/
@@ -20,10 +20,15 @@ PKGDIR=`readlink -f $PKGDIR`
 BUILDDIR=`readlink -f $BUILDDIR`
 
 if ! (test -d $BBDIR && test -d $PKGDIR && test -d $BUILDDIR); then
-    echo >&2 "Error: Not all directories exist!"
+    echo >&2 "Error: Not all directories exist! Did you run this script in poky directory?"
     exit 1
 fi
-       
+
+if !(test -r $PKGDIR/conf/local.conf); then
+   echo "Setting up initial '$PKGDIR/conf/local.conf'."
+   cat $PKGDIR/conf/local.conf.sample | sed -e"s|POKYROOT|${OEROOT}|" > $PKGDIR/conf/local.conf
+fi     
+
 BBPATH=$BBDIR
 if test x"$BBDIR" != x"$PKGDIR"; then
        BBPATH=$PKGDIR:$BBPATH