]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: kernel configuration cleanups
authorBruce Ashfield <bruce.ashfield@windriver.com>
Wed, 21 Sep 2011 18:57:48 +0000 (18:57 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Sep 2011 02:07:37 +0000 (03:07 +0100)
There were some config fragment warnings that were being hidden
by virtue of being output while generating the full config versus
the ones that were generated during the configuration audit task.

This change does the following:

  - Updates the kern-tools SRCREV to include changes that move
    all kernel configuration warnings to the audit script

  - Updates the meta SRCREV for linux-yocto to get updated
    kernel configuration fragments that are warning-free. These
    are duplicated configs, and other changes that have a net
    result of no runtime changes.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
meta/recipes-kernel/linux/linux-yocto_3.0.bb

index edaaea6d27cfa8fe9a8673ebebe78c5f72404295..87aa5748d567c599643d472e17954e72b3172c9a 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
 
 DEPENDS = "git-native guilt-native"
 
-SRCREV = "60723c84395a9ac1753589824e30be39a781bb82"
+SRCREV = "364437739c45a5e771d1f7b3ac73c35f1328fd97"
 PR = r10
 PV = "0.1+git${SRCPV}"
 
index eb329c56c63477199b40344d5d12100b706c78aa..2b7a4f9ecdb743a77e7a47cca95b63101c6645ec 100644 (file)
@@ -16,7 +16,7 @@ LINUX_KERNEL_TYPE = "preempt-rt"
 
 SRCREV_machine ?= "0936e13cc65d816f1759e2322c5e3fc82a5037f3"
 SRCREV_machine_qemuppc ?= "0936e13cc65d816f1759e2322c5e3fc82a5037f3"
-SRCREV_meta ?= "334b8479297954d94c97f81164e3363ed7ae70e5"
+SRCREV_meta ?= "0dcdf7bb40a8e1fb18fd27d442fa5ace8cff4941"
 
 PR = "r1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 01609664eb43b9cdfc24d7f7c663d2c99a0dd169..f11c0eaab4c3d1f99b877be3e710d7b4f4536027 100644 (file)
@@ -18,7 +18,7 @@ SRCREV_machine_qemuppc ?= "eccd57eaa4c2b580b9adbbc39e19ecbff56779ae"
 SRCREV_machine_qemux86 ?= "72671808fdbe69a9fe03fd8f094e7c59da04a28c"
 SRCREV_machine_qemux86-64 ?= "2b2d0954a6fd12b4bb7f02f019bc62633c8060a1"
 SRCREV_machine ?= "6b2c7d65b844e686eae7d5cccb9b638887afe28e"
-SRCREV_meta ?= "334b8479297954d94c97f81164e3363ed7ae70e5"
+SRCREV_meta ?= "0dcdf7bb40a8e1fb18fd27d442fa5ace8cff4941"
 
 PR = "r2"
 PV = "${LINUX_VERSION}+git${SRCPV}"