]> code.ossystems Code Review - openembedded-core.git/commitdiff
git-native: Sync minor tweaks from OE
authorRichard Purdie <richard@openedhand.com>
Fri, 30 Nov 2007 16:52:28 +0000 (16:52 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 30 Nov 2007 16:52:28 +0000 (16:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3286 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/git/files/autotools.patch [new file with mode: 0644]
meta/packages/git/git-native_1.5.3.bb
meta/packages/git/git.inc

diff --git a/meta/packages/git/files/autotools.patch b/meta/packages/git/files/autotools.patch
new file mode 100644 (file)
index 0000000..0666118
--- /dev/null
@@ -0,0 +1,26 @@
+Index: git-1.5.2.3/configure.ac
+===================================================================
+--- git-1.5.2.3.orig/configure.ac      2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/configure.ac   2007-08-04 00:02:13.000000000 +0200
+@@ -235,7 +235,8 @@
+               else if (strcmp(buf, "12345"))
+                 exit(2);]])],
+       [ac_cv_c_c99_format=yes],
+-      [ac_cv_c_c99_format=no])
++      [ac_cv_c_c99_format=no],
++      [ac_cv_c_c99_format=yes])
+ ])
+ if test $ac_cv_c_c99_format = no; then
+       NO_C99_FORMAT=YesPlease
+Index: git-1.5.2.3/config.mak.in
+===================================================================
+--- git-1.5.2.3.orig/config.mak.in     2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/config.mak.in  2007-08-04 00:07:04.000000000 +0200
+@@ -3,6 +3,7 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ AR = @AR@
+ TAR = @TAR@
+ #INSTALL = @INSTALL@          # needs install-sh or install.sh in sources
index f91fd03ab163d3df35ae75bd6e2ae71ed5294c4b..935c773c1c1751def4244951391ea622ef0258d6 100644 (file)
@@ -1,3 +1,4 @@
 require git.inc
 inherit native
-DEPENDS = "openssl-native curl-native"
+DEPENDS = "openssl-native curl-native zlib-native expat-native"
+PR = "r1"
index 384dfaaeec954412e437798c2a4e3c5bceecd828..7115d44b353c6ea900fbd50db6168e4d5320f175 100644 (file)
@@ -2,9 +2,14 @@ DESCRIPTION = "The git revision control system used by the Linux kernel develope
 SECTION = "console/utils"
 LICENSE = "GPL"
 
-SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+           file://autotools.patch;patch=1"
 S = "${WORKDIR}/git-${PV}"
 
+EXTRA_OEMAKE = "NO_TCLTL=1"
+
+inherit autotools
+
 do_install () {
        oe_runmake install prefix=${D} bindir=${D}${bindir} \
                template_dir=${D}${datadir}/git-core/templates \
@@ -12,4 +17,3 @@ do_install () {
 }
 
 FILES_${PN} += "${datadir}/git-core"
-