]> code.ossystems Code Review - openembedded-core.git/commitdiff
formfactor: Add machconfig in qemux86-64 to avoid HAVE_KEYBOARD unset.
authorZhai Edwin <edwin.zhai@intel.com>
Wed, 15 Sep 2010 03:55:45 +0000 (11:55 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Fri, 17 Sep 2010 18:33:26 +0000 (11:33 -0700)
This prevent matchbox-kerboard starting as daemon automatically.

Also fix minor issue of netbase on qemux86-64, and add the machine in
local.conf.sample

[BUGID #308] fixed by this.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
meta/conf/local.conf.sample
meta/recipes-bsp/formfactor/files/qemux86-64/machconfig [new file with mode: 0755]
meta/recipes-core/netbase/netbase_4.41.bb

index f9a1431efebe9392c8bf8c44125361b32fec9687..052c1a940678bf4455e3fc4eea5548ebb5db427b 100644 (file)
@@ -20,6 +20,7 @@ MACHINE ?= "qemux86"
 
 # Other supported machines
 #MACHINE ?= "qemuarm"
+#MACHINE ?= "qemux86-64"
 #MACHINE ?= "netbook"
 #MACHINE ?= "c7x0"
 #MACHINE ?= "akita"
diff --git a/meta/recipes-bsp/formfactor/files/qemux86-64/machconfig b/meta/recipes-bsp/formfactor/files/qemux86-64/machconfig
new file mode 100755 (executable)
index 0000000..56a2ae2
--- /dev/null
@@ -0,0 +1,10 @@
+HAVE_TOUCHSCREEN=1
+HAVE_KEYBOARD=1
+DISPLAY_CAN_ROTATE=0
+DISPLAY_ORIENTATION=0
+#DISPLAY_WIDTH_PIXELS=640
+#DISPLAY_HEIGHT_PIXELS=480
+#DISPLAY_BPP=16
+DISPLAY_DPI=150
+DISPLAY_SUBPIXEL_ORDER=vrgb
index 90725b241e3780e65952b5f4f5d78c7a2133a6e1..8c31df9ac85ac12b5ec08893171f39345dca2d6d 100644 (file)
@@ -38,7 +38,7 @@ do_install () {
 
        # Disable network manager on machines that commonly do NFS booting
        case "${MACHINE}" in
-               "omap-3430sdp" | "omap-3430ldp" | "omap-2430sdp" | "qemuarm" | "qemux86" )
+               "omap-3430sdp" | "omap-3430ldp" | "omap-2430sdp" | "qemuarm" | "qemux86" | "qemux86-64" )
                        touch ${D}${sysconfdir}/network/nm-disabled-eth0
                        ;;
                *)
@@ -53,3 +53,4 @@ PACKAGE_ARCH_omap-3430ldp = "${MACHINE_ARCH}"
 PACKAGE_ARCH_omap-2430sdp = "${MACHINE_ARCH}"
 PACKAGE_ARCH_qemuarm = "${MACHINE_ARCH}"
 PACKAGE_ARCH_qemux86 = "${MACHINE_ARCH}"
+PACKAGE_ARCH_qemux86-64 = "${MACHINE_ARCH}"