]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter-1.6: fix tarball md5sum and add json-glib to dependencies
authorJoshua Lock <josh@linux.intel.com>
Mon, 4 Apr 2011 13:26:40 +0000 (14:26 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Apr 2011 04:42:43 +0000 (05:42 +0100)
* As of Clutter 1.5.2 the project no longer ships an internal version of
json-glib so we must explicitly add it to the DEPENDS.
* Fix the SRC_URI[md5sum]

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/recipes-graphics/clutter/clutter-1.6_1.6.8.bb

index 04935e3e9064aec672d6837ca27c0e325be0c750..ffcc42d3ee129f1585dff74679a75b2e60658bec 100644 (file)
@@ -2,6 +2,9 @@ require recipes-graphics/clutter/clutter.inc
 
 PR = "r0"
 
+# Internal json-glib was removed in Clutter 1.5.2
+STDDEPENDS += "json-glib"
+
 PACKAGES =+ "${PN}-examples"
 FILES_${PN}-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
 
@@ -14,8 +17,6 @@ S = "${WORKDIR}/clutter-1.6.8"
 
 BASE_CONF += "--disable-introspection"
 
-EXTRA_OECONF += "--with-json=check"
-
 do_configure_prepend () {
        # Disable DOLT
        sed -i -e 's/^DOLT//' ${S}/configure.ac