]> code.ossystems Code Review - openembedded-core.git/commitdiff
bluez-utils: added dependencies and restart function to init script
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 1 Aug 2008 12:55:06 +0000 (12:55 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 1 Aug 2008 12:55:06 +0000 (12:55 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4999 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/bluez/bluez-utils/add-init-deps.patch [new file with mode: 0644]
meta/packages/bluez/bluez-utils/add-restart.patch [new file with mode: 0644]
meta/packages/bluez/bluez-utils_3.18.bb

diff --git a/meta/packages/bluez/bluez-utils/add-init-deps.patch b/meta/packages/bluez/bluez-utils/add-init-deps.patch
new file mode 100644 (file)
index 0000000..45bcce5
--- /dev/null
@@ -0,0 +1,21 @@
+---
+ scripts/bluetooth.init |    8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+--- bluez-utils-3.18.orig/scripts/bluetooth.init
++++ bluez-utils-3.18/scripts/bluetooth.init
+@@ -1,6 +1,14 @@
+ #!/bin/sh
++### BEGIN INIT INFO
++# Provides: bluetooth
++# Required-Start:    $local_fs $syslog $remote_fs dbus
++# Required-Stop:     $local_fs $syslog $remote_fs
++# Default-Start:     2 3 4 5
++# Default-Stop:      0 1 6
++# Short-Description: Start bluetooth daemons
++### END INIT INFO
+ #
+ # Start/stop the Bluetooth daemons
+ #
+ set -e
diff --git a/meta/packages/bluez/bluez-utils/add-restart.patch b/meta/packages/bluez/bluez-utils/add-restart.patch
new file mode 100644 (file)
index 0000000..e37beff
--- /dev/null
@@ -0,0 +1,21 @@
+---
+ scripts/bluetooth.init |    4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- bluez-utils-3.18.orig/scripts/bluetooth.init
++++ bluez-utils-3.18/scripts/bluetooth.init
+@@ -47,10 +47,14 @@ case "$1" in
+       echo -n "Stopping $DESC:"
+       killall $DAEMON_NAME > /dev/null 2>&1 || true
+       echo -n " $DAEMON_NAME"
+       echo "."
+       ;;
++  restart)
++    $0 stop
++      $0 start
++    ;;
+   *)
+       N=/etc/init.d/$NAME
+       echo "Usage: $N {start|stop}" >&2
+       exit 1
+       ;;
index 50004e3cb200b49736c6df847b59fe0c7b9d8aa7..093064ad3515a337d68382590720a221d176d186 100644 (file)
@@ -1,12 +1,14 @@
 require bluez-utils.inc
 
 DEPENDS += "glib-2.0"
-PR = "r3"
+PR = "r4"
 
 # ti patch doesn't apply, people using it should rediff it and send it upstream
 #SRC_URI += "file://hciattach-ti-bts.patch;patch=1 "
 
-SRC_URI += "file://allow-no-hal.patch;patch=1 "
+SRC_URI += "file://allow-no-hal.patch;patch=1 \
+            file://add-init-deps.patch;patch=1 \
+           file://add-restart.patch;patch=1"
 
 EXTRA_OECONF = " \
                  --enable-bccmd \