]> code.ossystems Code Review - openembedded-core.git/commitdiff
nfs-utils: start/stop also statd so clients will be able to do locking
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 28 Aug 2007 12:59:46 +0000 (12:59 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 28 Aug 2007 12:59:46 +0000 (12:59 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2578 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/nfs-utils/files/nfsserver
meta/packages/nfs-utils/nfs-utils_1.0.6.bb

index bb16806ed9b97ae3c58420ea2871b73a9b02ff08..0e9d7be787bbbe4f925c462ead30231aa58c7dce 100644 (file)
@@ -7,9 +7,10 @@
 # Other control variables may be overridden here too
 test -r /etc/default/nfsd && . /etc/default/nfsd
 #
-# Location of exectuables:
+# Location of executables:
 test -x "$NFS_MOUNTD" || NFS_MOUNTD=/usr/sbin/mountd
 test -x "$NFS_NFSD" || NFS_NFSD=/usr/sbin/nfsd
+test -x "$NFS_STATD" || NFS_STATD=/usr/sbin/statd
 #
 # The user mode program must also exist (it just starts the kernel
 # threads using the kernel module code).
@@ -104,6 +105,20 @@ stop_nfsd(){
                echo failed
        fi
 }
+
+#statd
+start_statd(){
+       echo -n "starting statd: "
+       start-stop-daemon --start --exec "$NFS_STATD"
+       echo done
+}
+stop_statd(){
+       # WARNING: this kills any process with the executable
+       # name 'statd'.
+       echo -n 'stopping statd: '
+       start-stop-daemon --stop --quiet --signal 1 --name statd
+       echo done
+}
 #----------------------------------------------------------------------
 #
 # supported options:
@@ -116,15 +131,19 @@ case "$1" in
 start) create_directories
        start_nfsd "$NFS_SERVERS"
        start_mountd
+       start_statd
        test -r /etc/exports && exportfs -a;;
 stop)  exportfs -ua
+       stop_statd
        stop_mountd
        stop_nfsd;;
 reload)        test -r /etc/exports && exportfs -r;;
 restart)exportfs -ua
        stop_mountd
+       stop_statd
        # restart does not restart the kernel threads,
        # only the user mode processes
        start_mountd
+       start_statd
        test -r /etc/exports && exportfs -a;;
 esac
index fbc2a96a3c33df03fb085b1aff8865c0dbec5f03..15e39144728faaefe638bb737696cab0c706ad0b 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "userspace utilities for kernel nfs"
 PRIORITY = "optional"
 SECTION = "console/network"
 LICENSE = "GPL"
-PR = "r11"
+PR = "r12"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
        file://acinclude-lossage.patch;patch=1 \