]> code.ossystems Code Review - openembedded-core.git/commitdiff
archive-patched-source.bbclass: Archive patched source
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Mon, 26 Mar 2012 10:27:40 +0000 (18:27 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Apr 2012 16:01:30 +0000 (17:01 +0100)
This bbclass inherits archiver.bbclass to archive patched source

[YOCTO #1977]

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
meta/classes/archive-patched-source.bbclass [new file with mode: 0644]

diff --git a/meta/classes/archive-patched-source.bbclass b/meta/classes/archive-patched-source.bbclass
new file mode 100644 (file)
index 0000000..a6d368f
--- /dev/null
@@ -0,0 +1,14 @@
+# This file is for getting archiving packages with patched sources(archive 's' before do_patch stage),logs(archive 'temp' after package_write_rpm),dump data and 
+# creating diff file(get all environment variables and functions in building and mapping all content in 's' including patches to  xxx.diff.gz.
+# All archived packages will be deployed in ${DEPLOY_DIR}/sources
+
+inherit archiver
+
+# Get archiving package with patched sources including patches
+do_patch[postfuncs] += "do_archive_patched_sources "
+
+# Get archiving package with logs(temp) and scripts(.bb and .inc files)
+do_package_write_rpm[prefuncs] += "do_archive_scripts_logs "
+
+# Get dump date and create diff file 
+do_package_write_rpm[postfuncs] += "do_dumpdata_create_diff_gz "