]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnupg: update 2.3.1 -> 2.3.2
authorAlexander Kanavin <alex@linutronix.de>
Wed, 8 Sep 2021 18:01:11 +0000 (20:01 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Oct 2021 17:31:04 +0000 (18:31 +0100)
Drop chunk from relocate.patch, the upstream code no longer exists.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/gnupg/gnupg/0001-configure.ac-use-a-custom-value-for-the-location-of-.patch
meta/recipes-support/gnupg/gnupg/relocate.patch
meta/recipes-support/gnupg/gnupg_2.3.2.bb [moved from meta/recipes-support/gnupg/gnupg_2.3.1.bb with 97% similarity]

index ecd62636269241bc54907b34517130f898afc88f..a66a8e62b0a6b48ed32d446506e7d70fb5d95a9d 100644 (file)
@@ -1,4 +1,4 @@
-From 52ba9d34cd9317145ee8a93afd5d73dd0cbf3182 Mon Sep 17 00:00:00 2001
+From c873c85b1ee1c35ebbba0bc80c2352c64787a5fd Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Mon, 22 Jan 2018 18:00:21 +0200
 Subject: [PATCH] configure.ac: use a custom value for the location of
@@ -14,10 +14,10 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/configure.ac b/configure.ac
-index 7a2d410..14a7203 100644
+index d03ea3b..a6dfa19 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1841,7 +1841,7 @@ AC_DEFINE_UNQUOTED(GPGCONF_DISP_NAME, "GPGConf",
+@@ -1958,7 +1958,7 @@ AC_DEFINE_UNQUOTED(GPGCONF_DISP_NAME, "GPGConf",
  
  AC_DEFINE_UNQUOTED(GPGTAR_NAME, "gpgtar", [The name of the gpgtar tool])
  
index 9b0f0a8ce0cd509d82586ef14110a634e150ac64..f9f38c2876c86f7e355a3726b13ddde5932afdb6 100644 (file)
@@ -1,4 +1,4 @@
-From d6992692d1c36983b709fe1ff049cc91ef2c408a Mon Sep 17 00:00:00 2001
+From 5a68a37ae2649e0988965cfe3a63a0142f0182a1 Mon Sep 17 00:00:00 2001
 From: Ross Burton <ross.burton@intel.com>
 Date: Wed, 19 Sep 2018 14:44:40 +0100
 Subject: [PATCH] Allow the environment to override where gnupg looks for its
@@ -8,23 +8,23 @@ Upstream-Status: Inappropriate [OE-specific]
 Signed-off-by: Ross Burton <ross.burton@intel.com>
 
 ---
- common/homedir.c | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
+ common/homedir.c | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
 
 diff --git a/common/homedir.c b/common/homedir.c
-index 85e09c4..e1410e2 100644
+index 7969a2c..06b8016 100644
 --- a/common/homedir.c
 +++ b/common/homedir.c
-@@ -788,7 +788,7 @@ gnupg_socketdir (void)
+@@ -918,7 +918,7 @@ gnupg_socketdir (void)
    if (!name)
      {
        unsigned int dummy;
 -      name = _gnupg_socketdir_internal (0, &dummy);
 +      name = getenv("GNUPG_SOCKETDIR") ?: _gnupg_socketdir_internal (0, &dummy);
+       gpgrt_annotate_leaked_object (name);
      }
  
-   return name;
-@@ -814,7 +814,7 @@ gnupg_sysconfdir (void)
+@@ -946,7 +946,7 @@ gnupg_sysconfdir (void)
      }
    return name;
  #else /*!HAVE_W32_SYSTEM*/
@@ -33,7 +33,7 @@ index 85e09c4..e1410e2 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -843,7 +843,7 @@ gnupg_bindir (void)
+@@ -978,7 +978,7 @@ gnupg_bindir (void)
    else
      return rdir;
  #else /*!HAVE_W32_SYSTEM*/
@@ -42,7 +42,7 @@ index 85e09c4..e1410e2 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -856,7 +856,7 @@ gnupg_libexecdir (void)
+@@ -991,7 +991,7 @@ gnupg_libexecdir (void)
  #ifdef HAVE_W32_SYSTEM
    return gnupg_bindir ();
  #else /*!HAVE_W32_SYSTEM*/
@@ -51,8 +51,8 @@ index 85e09c4..e1410e2 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -870,7 +870,7 @@ gnupg_libdir (void)
-     name = xstrconcat (w32_rootdir (), DIRSEP_S "lib" DIRSEP_S "gnupg", NULL);
+@@ -1008,7 +1008,7 @@ gnupg_libdir (void)
+     }
    return name;
  #else /*!HAVE_W32_SYSTEM*/
 -  return GNUPG_LIBDIR;
@@ -60,8 +60,8 @@ index 85e09c4..e1410e2 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -884,7 +884,7 @@ gnupg_datadir (void)
-     name = xstrconcat (w32_rootdir (), DIRSEP_S "share" DIRSEP_S "gnupg", NULL);
+@@ -1026,7 +1026,7 @@ gnupg_datadir (void)
+     }
    return name;
  #else /*!HAVE_W32_SYSTEM*/
 -  return GNUPG_DATADIR;
@@ -69,8 +69,8 @@ index 85e09c4..e1410e2 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -900,7 +900,7 @@ gnupg_localedir (void)
-                        NULL);
+@@ -1045,7 +1045,7 @@ gnupg_localedir (void)
+     }
    return name;
  #else /*!HAVE_W32_SYSTEM*/
 -  return LOCALEDIR;
@@ -78,12 +78,3 @@ index 85e09c4..e1410e2 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -971,7 +971,7 @@ gnupg_cachedir (void)
-     }
-   return dir;
- #else /*!HAVE_W32_SYSTEM*/
--  return GNUPG_LOCALSTATEDIR "/cache/" PACKAGE_NAME;
-+  return getenv("GNUPG_LOCALSTATEDIR") ?: GNUPG_LOCALSTATEDIR "/cache/" PACKAGE_NAME;
- #endif /*!HAVE_W32_SYSTEM*/
- }
similarity index 97%
rename from meta/recipes-support/gnupg/gnupg_2.3.1.bb
rename to meta/recipes-support/gnupg/gnupg_2.3.2.bb
index 411ea9579dd354fa03ce9592a51b5866982afbd0..f3b277b0a8d5a7e12a52983411b5a34e23f9d6f8 100644 (file)
@@ -24,7 +24,7 @@ SRC_URI:append:class-native = " file://0001-configure.ac-use-a-custom-value-for-
                                 file://relocate.patch"
 SRC_URI:append:class-nativesdk = " file://relocate.patch"
 
-SRC_URI[sha256sum] = "c498db346a9b9a4b399e514c8f56dfc0a888ce8f327f10376ff984452cd154ec"
+SRC_URI[sha256sum] = "e1d953e0e296072fca284215103ef168885eaac596c4660c5039a36a83e3041b"
 
 EXTRA_OECONF = "--disable-ldap \
                --disable-ccid-driver \