]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add dpkg, modified from upstream oe.
authorChris Larson <kergoth@openedhand.com>
Tue, 5 Sep 2006 07:24:58 +0000 (07:24 +0000)
committerChris Larson <kergoth@openedhand.com>
Tue, 5 Sep 2006 07:24:58 +0000 (07:24 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@696 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/dpkg/dpkg-native_1.13.22.bb [new file with mode: 0644]
meta/packages/dpkg/dpkg.inc [new file with mode: 0644]
meta/packages/dpkg/dpkg_1.13.22.bb [new file with mode: 0644]
meta/packages/dpkg/files/autofoo.patch [new file with mode: 0644]
meta/packages/dpkg/files/noman.patch [new file with mode: 0644]

diff --git a/meta/packages/dpkg/dpkg-native_1.13.22.bb b/meta/packages/dpkg/dpkg-native_1.13.22.bb
new file mode 100644 (file)
index 0000000..2f196c2
--- /dev/null
@@ -0,0 +1,12 @@
+require dpkg.inc
+SRC_URI += "file://noman.patch;patch=1"
+
+inherit native
+inherit autotools gettext
+
+EXTRA_OECONF = "--without-static-progs \
+               --without-dselect \
+               --with-start-stop-daemon \
+               --with-zlib \
+               --with-bz2lib \
+               --without-sgml-doc"
diff --git a/meta/packages/dpkg/dpkg.inc b/meta/packages/dpkg/dpkg.inc
new file mode 100644 (file)
index 0000000..3c3f29c
--- /dev/null
@@ -0,0 +1,10 @@
+DESCRIPTION = "Package maintenance system for Debian."
+LICENSE = "GPL"
+SECTION = "base"
+DEPENDS = "ncurses zlib"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz"
+S = "${WORKDIR}/dpkg-${PV}"
+
+PARALLEL_MAKE = ""
diff --git a/meta/packages/dpkg/dpkg_1.13.22.bb b/meta/packages/dpkg/dpkg_1.13.22.bb
new file mode 100644 (file)
index 0000000..08a9c06
--- /dev/null
@@ -0,0 +1,11 @@
+require dpkg.inc
+DEPENDS += "bzip2"
+
+inherit autotools gettext
+
+EXTRA_OECONF = "--without-static-progs \
+               --without-dselect \
+               --with-start-stop-daemon \
+               --with-zlib \
+               --with-bz2lib \
+               --without-sgml-doc"
diff --git a/meta/packages/dpkg/files/autofoo.patch b/meta/packages/dpkg/files/autofoo.patch
new file mode 100644 (file)
index 0000000..691121e
--- /dev/null
@@ -0,0 +1,48 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- dpkg-1.10.23/configure.in~autofoo
++++ dpkg-1.10.23/configure.in
+@@ -227,21 +227,36 @@
+ # OpenBSD passes AC_TRY_COMPILE for va_copy even though 
+ # it doesn't seem to exist, which is odd. We need to use
+ # AC_TRY_RUN.
++#
++# If crosscompiling, use AC_TRY_COMPILE. -CL
+ AC_TRY_RUN([
+ #include <stdarg.h>
+ main(){
+ va_list v1,v2;
+ va_copy(v1, v2);
+ exit(0);}
+-], [AC_MSG_RESULT(yes)
+-AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])],[AC_MSG_RESULT(no)
+-AC_MSG_CHECKING([for va_list assignment copy])
++], [dpkg_cv_va_copy=yes], [dpkg_cv_va_copy=no],
+ AC_TRY_COMPILE([
+ #include <stdarg.h>
++main(){
++va_list v1,v2;
++va_copy(v1, v2);
++exit(0);}
++], [dpkg_cv_va_copy=yes], [dpkg_vc_va_copy=no]))
++
++if test "$dpkg_cv_va_copy" = "yes"; then
++      AC_MSG_RESULT(yes)
++      AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])
++else
++      AC_MSG_RESULT(no)
++      AC_MSG_CHECKING([for va_list assignment copy])
++      AC_TRY_COMPILE([
++#include <stdarg.h>
+ ],[
+ va_list v1,v2;
+ v1 = v2;
+-], AC_MSG_RESULT(yes),AC_MSG_ERROR(no))])
++], AC_MSG_RESULT(yes), AC_MSG_ERROR(no))
++fi
+ DPKG_C_GCC_ATTRIBUTE([,,],supported,[int x],[,,],ATTRIB,[Define if function attributes a la GCC 2.5 and higher are available.],
+   DPKG_C_GCC_ATTRIBUTE(noreturn,noreturn,[int x],noreturn,NORETURN,[Define if nonreturning functions a la GCC 2.5 and higher are available.])
diff --git a/meta/packages/dpkg/files/noman.patch b/meta/packages/dpkg/files/noman.patch
new file mode 100644 (file)
index 0000000..f5984fe
--- /dev/null
@@ -0,0 +1,16 @@
+---
+ Makefile.am |    3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+--- dpkg-1.13.22.orig/Makefile.am
++++ dpkg-1.13.22/Makefile.am
+@@ -15,8 +15,7 @@ SUBDIRS = \
+       utils \
+       scripts \
+       po \
+-      origins \
+-      man
++      origins
+ ACLOCAL_AMFLAGS = -I m4