]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng: Add tracing group when building lttng-tools
authorMehaffey, John <John_Mehaffey@mentor.com>
Fri, 27 Feb 2015 02:17:20 +0000 (02:17 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Mar 2015 17:38:42 +0000 (17:38 +0000)
This prevents the "Warning: No tracing group detected" message
from lttng when there is no group 'tracing' while using lttng
on the target.

Signed-off-by: John Mehaffey <mehaf@gedanken.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/lttng/lttng-tools_2.6.0.bb

index 15125e3324deb41abda75b10d25a0818b3ae6185..f0969b5241ceb9f06688983083210834f00b7685 100644 (file)
@@ -30,7 +30,10 @@ SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.6 \
 
 S = "${WORKDIR}/git"
 
-inherit autotools-brokensep ptest pkgconfig
+inherit autotools-brokensep ptest pkgconfig useradd
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "tracing"
 
 export KERNELDIR="${STAGING_KERNEL_DIR}"