]> code.ossystems Code Review - openembedded-core.git/commitdiff
lame: always link with libm (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 13:33:45 +0000 (13:33 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 13:33:45 +0000 (13:33 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3008 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/lame/lame/Makefile-lm.patch [new file with mode: 0644]
meta/packages/lame/lame_3.96.1.bb

diff --git a/meta/packages/lame/lame/Makefile-lm.patch b/meta/packages/lame/lame/Makefile-lm.patch
new file mode 100644 (file)
index 0000000..cbbb170
--- /dev/null
@@ -0,0 +1,22 @@
+--- lame-3.96.1/libmp3lame/Makefile.am.old     2007-01-16 13:41:48.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.am 2007-01-16 13:41:53.000000000 +0000
+@@ -18,7 +18,7 @@
+ decoder_ldadd =
+ endif
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+                       -no-undefined
+--- lame-3.96.1/libmp3lame/Makefile.in.old     2007-01-16 13:47:17.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.in 2007-01-16 13:47:29.000000000 +0000
+@@ -177,7 +177,7 @@
+ @LIB_WITH_DECODER_TRUE@decoder_ldadd = $(top_builddir)/mpglib/libmpgdecoder.la
+ @LIB_WITH_DECODER_FALSE@decoder_ldadd = 
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+                       -no-undefined
index edb4265f138cf8cb38c45e855114ea075bccba50..0c5c24582922ae17cdb2360d501f13fecae72096 100644 (file)
@@ -1,10 +1,11 @@
 SECTION = "console/utils"
 DESCRIPTION = "Not an MP3 encoder"
 LICENSE = "LGPL"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
-       file://no-gtk1.patch;patch=1"
+       file://no-gtk1.patch;patch=1 \
+       file://Makefile-lm.patch;patch=1"
 
 inherit autotools