]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils: Add code to consider musl when selecting charsets
authorKhem Raj <raj.khem@gmail.com>
Thu, 16 Apr 2015 02:00:19 +0000 (19:00 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Apr 2015 06:19:04 +0000 (07:19 +0100)
The real issue is in gnulib where it should be fixed
but gnulib gets imported in source into various components
and that may take a while. So lets fix the componnets versions
and as/if they land in new gnulib with a fix we can take
it off.

Change-Id: I63bbcb7bc4d92cb1ec74bb4f4f5109a377060253
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/coreutils/coreutils-8.23/0001-Unset-need_charset_alias-when-building-for-musl.patch [new file with mode: 0644]
meta/recipes-core/coreutils/coreutils_8.23.bb

diff --git a/meta/recipes-core/coreutils/coreutils-8.23/0001-Unset-need_charset_alias-when-building-for-musl.patch b/meta/recipes-core/coreutils/coreutils-8.23/0001-Unset-need_charset_alias-when-building-for-musl.patch
new file mode 100644 (file)
index 0000000..abdfa2a
--- /dev/null
@@ -0,0 +1,33 @@
+From b9565dc2fe0c4f7daaec91b7e83bc7313dee2f4a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 13 Apr 2015 17:02:13 -0700
+Subject: [PATCH] Unset need_charset_alias when building for musl
+
+localcharset uses ac_cv_gnu_library_2_1 from glibc21.m4
+which actually shoudl be fixed in gnulib and then all downstream
+projects will get it eventually. For now we apply the fix to
+coreutils
+
+Upstream-Status: Not Required
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lib/gnulib.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/gnulib.mk b/lib/gnulib.mk
+index e1d74db..c0e92dd 100644
+--- a/lib/gnulib.mk
++++ b/lib/gnulib.mk
+@@ -1882,7 +1882,7 @@ install-exec-localcharset: all-local
+         case '$(host_os)' in \
+           darwin[56]*) \
+             need_charset_alias=true ;; \
+-          darwin* | cygwin* | mingw* | pw32* | cegcc*) \
++          darwin* | cygwin* | mingw* | pw32* | cegcc* | linux-musl*) \
+             need_charset_alias=false ;; \
+           *) \
+             need_charset_alias=true ;; \
+-- 
+2.1.4
+
index 63df75e7baf29796a266923db717e1fd1a3cd1d5..70c04a5f116e2b721f3490c564c42a0b7aa4911f 100644 (file)
@@ -17,6 +17,7 @@ SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz;name=tarball \
            file://man-decouple-manpages-from-build.patch \
            file://remove-usr-local-lib-from-m4.patch \
            file://fix-selinux-flask.patch \
+           file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
           "
 
 SRC_URI[tarball.md5sum] = "abed135279f87ad6762ce57ff6d89c41"