]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdk-pixbuf: handle postinstall errors differently
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Mon, 10 Dec 2012 14:31:21 +0000 (16:31 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 13 Dec 2012 14:28:40 +0000 (14:28 +0000)
Apparently gdk-pixbuf-query-loaders always returns 0 but writes any
errors to stderr. So, the conditional exit at the end of the command was
useless. Write the errors to a file and exit only if the file size is
greater than 0.

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb

index 2377d0eec1c3841b1ef536aebb8835b479cf8dd0..33a43becaa4f148c92683940986b83a48ed189bc 100644 (file)
@@ -63,12 +63,26 @@ if [ "x$D" != "x" ]; then
 # we trick the gdk-pixbuf-query-loaders into scanning the native shared
 # objects and then we remove the NATIVE_ROOT prefix from the paths in
 # loaders.cache.
-gdk-pixbuf-query-loaders $(find $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders \
-        -name *.so | sed -e "s:$D:$NATIVE_ROOT:g") > \
-        $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache || exit 1
+gdk-pixbuf-query-loaders $(ls -d -1 $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.so |\
+        sed -e "s:$D:$NATIVE_ROOT:g") > \
+        $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \
+        2>$D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.err
+
+# gdk-pixbuf-query-loaders always returns 0, so we need to check if loaders.err
+# has anything in it
+if [ -s $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.err ]; then
+       echo "${PN} postinstall scriptlet failed:"
+       cat $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.err
+       rm $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.err
+       # we've got errors, postpone postinstall for first boot
+       exit 1
+fi
 
 sed -i -e "s:$NATIVE_ROOT:/:g" $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
 
+# remove the empty loaders.err
+rm $D/${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.err
+
 exit 0
 fi