]> code.ossystems Code Review - openembedded-core.git/commitdiff
gobject-introspection: Add an initial version, not functional yet
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 14 May 2009 14:08:33 +0000 (15:08 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 14 May 2009 14:08:33 +0000 (15:08 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/conf/distro/include/poky-fixed-revisions.inc
meta/packages/gnome/gobject-introspection/pathfix.patch [new file with mode: 0644]
meta/packages/gnome/gobject-introspection_git.bb [new file with mode: 0644]

index 97c8da6897fe9056244aedb6a67cb419c78b2594..d43a881c1cbced5dfe156f3d77ef9d51e07eacbb 100644 (file)
@@ -187,6 +187,8 @@ SRCREV_pn-gnet = "495"
 SRCREV_pn-tasks ?= "430"
 SRCREV_pn-librsvg ?= "1193"
 SRCREV_pn-qemugl = "d888bbc723c00d197d34a39b5b7448660ec1b1c0"
+SRCREV_pn-gobject-introspection = "c54f10f4caef35b42229c48951ee647ef05ab557"
+SRCREV_pn-gobject-introspection-native = "c54f10f4caef35b42229c48951ee647ef05ab557"
 
 # Preferred Versions:
 #
diff --git a/meta/packages/gnome/gobject-introspection/pathfix.patch b/meta/packages/gnome/gobject-introspection/pathfix.patch
new file mode 100644 (file)
index 0000000..d640ddb
--- /dev/null
@@ -0,0 +1,53 @@
+Index: git/gir/Makefile.am
+===================================================================
+--- git.orig/gir/Makefile.am   2009-05-12 14:37:40.000000000 +0100
++++ git/gir/Makefile.am        2009-05-12 14:37:40.000000000 +0100
+@@ -40,7 +40,7 @@
+           -I$(GLIB_LIBDIR)/glib-2.0/include \
+           -DGETTEXT_PACKAGE=Dummy \
+           -D__G_I18N_LIB_H__ \
+-          $(GLIB_LIBDIR)/glib-2.0/include/glibconfig.h \
++          $(GLIB_INCLUDEDIR)/glibconfig.h \
+           $(srcdir)/glib-2.0.c \
+           $(GLIB_INCLUDEDIR)/glib/*.h
+       $(SCANNER) $(SCANNER_ARGS) \
+Index: git/giscanner/dumper.py
+===================================================================
+--- git.orig/giscanner/dumper.py       2009-05-12 14:37:40.000000000 +0100
++++ git/giscanner/dumper.py    2009-05-12 14:37:40.000000000 +0100
+@@ -79,7 +79,7 @@
+         self._tmpdir = tempfile.mkdtemp('', 'tmp-introspect')
+         self._compiler_cmd = os.environ.get('CC', 'gcc')
+-        self._linker_cmd = os.environ.get('LD', self._compiler_cmd)
++        self._linker_cmd = os.environ.get('CCLD', self._compiler_cmd)
+         self._pkgconfig_cmd = os.environ.get('PKG_CONFIG', 'pkg-config')
+         self._uninst_srcdir = os.environ.get(
+Index: git/giscanner/scannermain.py
+===================================================================
+--- git.orig/giscanner/scannermain.py  2009-05-12 14:37:40.000000000 +0100
++++ git/giscanner/scannermain.py       2009-05-12 14:37:40.000000000 +0100
+@@ -282,6 +282,7 @@
+     shown_include_warning = False
+     for include in options.includes:
+         if os.sep in include:
++            continue
+             raise ValueError("Invalid include path %r" % (include, ))
+         include_obj = Include.from_string(include)
+         transformer.register_include(include_obj)
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac      2009-05-12 14:37:40.000000000 +0100
++++ git/configure.ac   2009-05-12 14:38:01.000000000 +0100
+@@ -191,7 +191,9 @@
+ esac
+ AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
+-SHAVE_INIT([scripts])
++SHAVE_SAVED_LIBTOOL=$LIBTOOL
++AC_SUBST(SHAVE_SAVED_LIBTOOL)
++
+ AC_CONFIG_FILES([
+ Makefile
+ gir/Makefile
diff --git a/meta/packages/gnome/gobject-introspection_git.bb b/meta/packages/gnome/gobject-introspection_git.bb
new file mode 100644 (file)
index 0000000..e098044
--- /dev/null
@@ -0,0 +1,20 @@
+SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
+           file://pathfix.patch;patch=1"
+
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libffi python-native gobject-introspection-native"
+DEPENDS_virtclass-native = "libffi-native python-native"
+
+inherit autotools_stage
+
+TARGET_CFLAGS += "-I${STAGING_INCDIR_NATIVE}/python2.5"
+
+do_configure_prepend () {
+       echo "EXTRA_DIST = " > ${S}/gtk-doc.make
+}
+
+BBCLASSEXTEND = "native"
\ No newline at end of file