]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: upgrade to version 2.7.7
authorQing He <qing.he@intel.com>
Fri, 18 Jun 2010 03:07:40 +0000 (11:07 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 30 Jun 2010 12:19:03 +0000 (13:19 +0100)
from 2.6.29
add homepage and bugtracker, update license

changes:
  - remove libxml-nanohttp.patch since it's already upstream
  - add ${libdir}/xml2Conf.sh into FILES_${PN}-dev

Signed-off-by: Qing He <qing.he@intel.com>
meta/packages/libxml/libxml2.inc
meta/packages/libxml/libxml2/libxml-nanohttp.patch [deleted file]
meta/packages/libxml/libxml2_2.7.7.bb [moved from meta/packages/libxml/libxml2_2.6.29.bb with 67% similarity]

index 1aa7132ceb1f575e88e209909073eb9fea3c9a65..6a763aa4da58e41679d1aa8833c6cacd1e8547c9 100644 (file)
@@ -1,13 +1,20 @@
 DESCRIPTION = "GNOME XML Parser library"
+HOMEPAGE = "http://www.xmlsoft.org/"
+BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
 SECTION = "libs"
 PRIORITY = "optional"
 LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bb90c48926316d9af6e2d70ca7013ade \
+                    file://hash.c;beginline=6;endline=15;md5=ce702952bfddd7aee22639a2d6b54136 \
+                    file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
+                    file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
+
+DEPENDS_virtclass-native = "python-native"
+DEPENDS =+ "zlib"
 
 SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
-           file://libxml-64bit.patch;patch=1 \
-          file://libxml-nanohttp.patch;patch=1"
+           file://libxml-64bit.patch"
 
-DEPENDS_virtclass-native = "python-native"
 
 inherit autotools pkgconfig binconfig
 
@@ -24,7 +31,7 @@ python populate_packages_prepend () {
 
 PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
 
-FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-dev += "${bindir}/*-config ${libdir}/xml2Conf.sh"
 FILES_${PN}-utils += "${bindir}/*"
 
 BBCLASSEXTEND = "native"
diff --git a/meta/packages/libxml/libxml2/libxml-nanohttp.patch b/meta/packages/libxml/libxml2/libxml-nanohttp.patch
deleted file mode 100644 (file)
index 550e036..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: libxml2-2.6.29/nanohttp.c
-===================================================================
---- libxml2-2.6.29.orig/nanohttp.c     2008-10-30 10:12:11.000000000 +0800
-+++ libxml2-2.6.29/nanohttp.c  2008-10-30 10:12:30.000000000 +0800
-@@ -1585,7 +1585,7 @@
-     if (!strcmp(filename, "-")) 
-         fd = 0;
-     else {
--        fd = open(filename, O_CREAT | O_WRONLY);
-+        fd = open(filename, O_CREAT | O_WRONLY, 0644);
-       if (fd < 0) {
-           xmlNanoHTTPClose(ctxt);
-           return(-1);
similarity index 67%
rename from meta/packages/libxml/libxml2_2.6.29.bb
rename to meta/packages/libxml/libxml2_2.7.7.bb
index 42253dd47547d6d8840361c92082320512d621c1..7e017c6ee3ea56cb3866e7e4526e1ed38c569551 100644 (file)
@@ -1,3 +1,3 @@
 require libxml2.inc
 
-PR = "r8"
+PR = "r0"