]> code.ossystems Code Review - openembedded-core.git/commitdiff
zlib: clean up ptest
authorRoss Burton <ross.burton@intel.com>
Tue, 26 Mar 2019 12:02:27 +0000 (12:02 +0000)
committerArmin Kuster <akuster808@gmail.com>
Sat, 13 Apr 2019 19:38:40 +0000 (12:38 -0700)
Instead of patching and sedding the makefile, just install test/example and
execute it in run-ptest.  example is the bulk of the test suite, as minimal as
it is.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/zlib/zlib/Makefile-runtests.patch [deleted file]
meta/recipes-core/zlib/zlib/run-ptest
meta/recipes-core/zlib/zlib_1.2.11.bb

diff --git a/meta/recipes-core/zlib/zlib/Makefile-runtests.patch b/meta/recipes-core/zlib/zlib/Makefile-runtests.patch
deleted file mode 100644 (file)
index 61eea82..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-Add 'ptest' target to Makefile, to run tests without checking dependencies.
-
-Signed-off-by: Anders Roxell <anders.roxell@enea.com>
-Upstream-Status: Pending
----
-diff -uNr a/Makefile.in b/Makefile.in
---- a/Makefile.in      2013-06-10 13:48:14.321959162 +0200
-+++ b/Makefile.in      2013-06-10 13:49:36.686476448 +0200
-@@ -83,6 +83,9 @@
- test: all teststatic testshared
- teststatic: static
-+      @make runteststatic
-+
-+runteststatic:
-       @TMPST=tmpst_$$; \
-       if echo hello world | ./minigzip | ./minigzip -d && ./example $$TMPST ; then \
-         echo '                *** zlib test OK ***'; \
-@@ -92,6 +95,9 @@
-       rm -f $$TMPST
- testshared: shared
-+      @make runtestshared
-+
-+runtestshared:
-       @LD_LIBRARY_PATH=`pwd`:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
-       LD_LIBRARYN32_PATH=`pwd`:$(LD_LIBRARYN32_PATH) ; export LD_LIBRARYN32_PATH; \
-       DYLD_LIBRARY_PATH=`pwd`:$(DYLD_LIBRARY_PATH) ; export DYLD_LIBRARY_PATH; \
-@@ -105,6 +111,9 @@
-       rm -f $$TMPSH
- test64: all64
-+      @make runtestall64
-+
-+runtestall64:
-       @TMP64=tmp64_$$; \
-       if echo hello world | ./minigzip64 | ./minigzip64 -d && ./example64 $$TMP64; then \
-         echo '                *** zlib 64-bit test OK ***'; \
index 884d9dc6996e1fe6a3e6aacb9620bb407f6031b1..065863ef754f0af6f8494135e487c2ed024488b7 100644 (file)
@@ -1,2 +1,7 @@
 #!/bin/sh
-make -k runteststatic runtestshared | sed -r -e 's/^(\s+\*+ (.+?) test OK \*+)/\1\nPASS: \2/' -e 's/^(\s+\*+ (.+?) test FAILED \*+)/\1\nFAIL: \2/'
+
+if ./examplesh ; then
+    echo "PASS: zlib"
+else
+    echo "FAIL: zlib"
+fi
index 41ec29d95e8e3dfdb0e4a535f269cafa81ab8a8e..ef9431ae475c0cde3a5fb4c58ce3d352f0d23b99 100644 (file)
@@ -7,7 +7,6 @@ LICENSE = "Zlib"
 LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/libpng/${BPN}/${PV}/${BPN}-${PV}.tar.xz \
-           file://Makefile-runtests.patch \
            file://ldflags-tests.patch \
            file://run-ptest \
            "
@@ -30,25 +29,12 @@ do_compile() {
        oe_runmake shared
 }
 
-do_compile_ptest() {
-       oe_runmake test
-}
-
 do_install() {
        oe_runmake DESTDIR=${D} install
 }
 
 do_install_ptest() {
-       install ${B}/Makefile   ${D}${PTEST_PATH}
-       install ${B}/example    ${D}${PTEST_PATH}
-       install ${B}/minigzip   ${D}${PTEST_PATH}
-       install ${B}/examplesh  ${D}${PTEST_PATH}
-       install ${B}/minigzipsh ${D}${PTEST_PATH}
-
-       # Remove buildhost references...
-       sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
-               -e 's|${DEBUG_PREFIX_MAP}||g' \
-        ${D}${PTEST_PATH}/Makefile
+       install ${B}/examplesh ${D}${PTEST_PATH}
 }
 
 # Move zlib shared libraries for target builds to $base_libdir so the library